summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-ushare
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-ushare
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-ushare')
-rw-r--r--applications/luci-ushare/Makefile4
-rw-r--r--applications/luci-ushare/ipkg/postinst6
-rw-r--r--applications/luci-ushare/luasrc/controller/ushare.lua27
-rw-r--r--applications/luci-ushare/luasrc/model/cbi/ushare.lua42
-rwxr-xr-xapplications/luci-ushare/root/etc/uci-defaults/luci-ushare11
5 files changed, 0 insertions, 90 deletions
diff --git a/applications/luci-ushare/Makefile b/applications/luci-ushare/Makefile
deleted file mode 100644
index 9b0a6e4abd..0000000000
--- a/applications/luci-ushare/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-PO = ushare
-
-include ../../build/config.mk
-include ../../build/module.mk
diff --git a/applications/luci-ushare/ipkg/postinst b/applications/luci-ushare/ipkg/postinst
deleted file mode 100644
index 54b1a33b4d..0000000000
--- a/applications/luci-ushare/ipkg/postinst
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
- ( . /etc/uci-defaults/luci-ushare ) && rm -f /etc/uci-defaults/luci-ushare
- /etc/init.d/ushare enabled || /etc/init.d/ushare enable
- exit 0
-}
diff --git a/applications/luci-ushare/luasrc/controller/ushare.lua b/applications/luci-ushare/luasrc/controller/ushare.lua
deleted file mode 100644
index eed853239b..0000000000
--- a/applications/luci-ushare/luasrc/controller/ushare.lua
+++ /dev/null
@@ -1,27 +0,0 @@
---[[
-
-LuCI uShare
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
-module("luci.controller.ushare", package.seeall)
-
-function index()
- if not nixio.fs.access("/etc/config/ushare") then
- return
- end
-
- local page
-
- page = entry({"admin", "services", "ushare"}, cbi("ushare"), _("uShare"), 60)
- page.dependent = true
-end
diff --git a/applications/luci-ushare/luasrc/model/cbi/ushare.lua b/applications/luci-ushare/luasrc/model/cbi/ushare.lua
deleted file mode 100644
index 7032b2d5ce..0000000000
--- a/applications/luci-ushare/luasrc/model/cbi/ushare.lua
+++ /dev/null
@@ -1,42 +0,0 @@
---[[
-
-LuCI uShare
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
-m = Map("ushare", translate("uShare"),
- luci.util.pcdata(translate("uShare is a UPnP (TM) A/V & DLNA Media Server. It implements the server component that provides UPnP media devices with information on available multimedia files.")))
-
-s = m:section(TypedSection, "ushare", translate("Settings"))
-s.addremove = false
-s.anonymous = true
-
-s:option(Flag, "enabled", translate("Enable"))
-
-s:option(Value, "username", translate("Username"))
-
-s:option(Value, "servername", translate("Servername"))
-
-dif = s:option( Value, "interface", translate("Interface"))
-for _, nif in ipairs(luci.sys.net.devices()) do
- if nif ~= "lo" then dif:value(nif) end
-end
-
-s:option(DynamicList, "content_directories", translate("Content directories"))
-
-s:option(Flag, "disable_webif", translate("Disable webinterface"))
-
-s:option(Flag, "disable_telnet", translate("Disable telnet console"))
-
-s:option(Value, "options", translate("Options"))
-
-return m
diff --git a/applications/luci-ushare/root/etc/uci-defaults/luci-ushare b/applications/luci-ushare/root/etc/uci-defaults/luci-ushare
deleted file mode 100755
index 8bcb6e4118..0000000000
--- a/applications/luci-ushare/root/etc/uci-defaults/luci-ushare
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-uci -q batch <<-EOF >/dev/null
- delete ucitrack.@ushare[-1]
- add ucitrack ushare
- set ucitrack.@ushare[-1].init=ushare
- commit ucitrack
-EOF
-
-rm -f /tmp/luci-indexcache
-exit 0