summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-polipo/luasrc/controller
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-polipo/luasrc/controller
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-polipo/luasrc/controller')
-rw-r--r--applications/luci-polipo/luasrc/controller/polipo.lua26
1 files changed, 0 insertions, 26 deletions
diff --git a/applications/luci-polipo/luasrc/controller/polipo.lua b/applications/luci-polipo/luasrc/controller/polipo.lua
deleted file mode 100644
index 1113f8f267..0000000000
--- a/applications/luci-polipo/luasrc/controller/polipo.lua
+++ /dev/null
@@ -1,26 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2008 Aleksandar Krsteski <alekrsteski@gmail.com>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-]]--
-
-module("luci.controller.polipo", package.seeall)
-
-function index()
- if not nixio.fs.access("/etc/config/polipo") then
- return
- end
-
- entry({"admin", "services", "polipo"}, alias("admin", "services", "polipo", "config"), _("Polipo"))
- entry({"admin", "services", "polipo", "status"}, template("polipo_status"), _("Status"))
- entry({"admin", "services", "polipo", "config"}, cbi("polipo"), _("Configuration"))
-end
-