summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-p910nd/luasrc/model
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-p910nd/luasrc/model
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-p910nd/luasrc/model')
-rw-r--r--applications/luci-p910nd/luasrc/model/cbi/p910nd.lua59
1 files changed, 0 insertions, 59 deletions
diff --git a/applications/luci-p910nd/luasrc/model/cbi/p910nd.lua b/applications/luci-p910nd/luasrc/model/cbi/p910nd.lua
deleted file mode 100644
index 7580a3e74e..0000000000
--- a/applications/luci-p910nd/luasrc/model/cbi/p910nd.lua
+++ /dev/null
@@ -1,59 +0,0 @@
---[[
-
-LuCI p910nd
-(c) 2008 Yanira <forum-2008@email.de>
-(c) 2012 Jo-Philipp Wich <jow@openwrt.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-local uci = luci.model.uci.cursor_state()
-local net = require "luci.model.network"
-local m, s, p, b
-
-m = Map("p910nd", translate("p910nd - Printer server"),
- translatef("First you have to install the packages to get support for USB (kmod-usb-printer) or parallel port (kmod-lp)."))
-
-net = net.init(m.uci)
-
-s = m:section(TypedSection, "p910nd", translate("Settings"))
-s.addremove = true
-s.anonymous = true
-
-s:option(Flag, "enabled", translate("enable"))
-
-s:option(Value, "device", translate("Device")).rmempty = true
-
-b = s:option(Value, "bind", translate("Interface"), translate("Specifies the interface to listen on."))
-b.template = "cbi/network_netlist"
-b.nocreate = true
-b.unspecified = true
-
-function b.cfgvalue(...)
- local v = Value.cfgvalue(...)
- if v then
- return (net:get_status_by_address(v))
- end
-end
-
-function b.write(self, section, value)
- local n = net:get_network(value)
- if n and n:ipaddr() then
- Value.write(self, section, n:ipaddr())
- end
-end
-
-p = s:option(ListValue, "port", translate("Port"), translate("TCP listener port."))
-p.rmempty = true
-for i=0,9 do
- p:value(i, 9100+i)
-end
-
-s:option(Flag, "bidirectional", translate("Bidirectional mode"))
-
-return m