summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-p910nd/luasrc/controller
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-p910nd/luasrc/controller
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-p910nd/luasrc/controller')
-rw-r--r--applications/luci-p910nd/luasrc/controller/p910nd.lua27
1 files changed, 0 insertions, 27 deletions
diff --git a/applications/luci-p910nd/luasrc/controller/p910nd.lua b/applications/luci-p910nd/luasrc/controller/p910nd.lua
deleted file mode 100644
index 4efaef8a1..000000000
--- a/applications/luci-p910nd/luasrc/controller/p910nd.lua
+++ /dev/null
@@ -1,27 +0,0 @@
---[[
-
-LuCI UVC Streamer
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
-module("luci.controller.p910nd", package.seeall)
-
-function index()
- if not nixio.fs.access("/etc/config/p910nd") then
- return
- end
-
- local page
-
- page = entry({"admin", "services", "p910nd"}, cbi("p910nd"), _("p910nd - Printer server"), 60)
- page.dependent = true
-end