summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-olsr/luasrc/tools
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-olsr/luasrc/tools
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-olsr/luasrc/tools')
-rw-r--r--applications/luci-olsr/luasrc/tools/olsr.lua42
1 files changed, 0 insertions, 42 deletions
diff --git a/applications/luci-olsr/luasrc/tools/olsr.lua b/applications/luci-olsr/luasrc/tools/olsr.lua
deleted file mode 100644
index dfd8262f0d..0000000000
--- a/applications/luci-olsr/luasrc/tools/olsr.lua
+++ /dev/null
@@ -1,42 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2011 Manuel Munz <freifunk at somakoma dot de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-]]--
-
-module("luci.tools.olsr", package.seeall)
-
-function etx_color(etx)
- local color = "#bb3333"
- if etx == 0 then
- color = "#bb3333"
- elseif etx < 2 then
- color = "#00cc00"
- elseif etx < 4 then
- color = "#ffcb05"
- elseif etx < 10 then
- color = "#ff6600"
- end
- return color
-end
-
-function snr_color(snr)
- local color = "#bb3333"
- if snr == 0 then
- color = "#bb3333"
- elseif snr > 30 then
- color = "#00cc00"
- elseif snr > 20 then
- color = "#ffcb05"
- elseif snr > 5 then
- color = "#ff6600"
- end
- return color
-end
-