summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-olsr/luasrc/controller/olsr6.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-olsr/luasrc/controller/olsr6.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-olsr/luasrc/controller/olsr6.lua')
-rw-r--r--applications/luci-olsr/luasrc/controller/olsr6.lua47
1 files changed, 0 insertions, 47 deletions
diff --git a/applications/luci-olsr/luasrc/controller/olsr6.lua b/applications/luci-olsr/luasrc/controller/olsr6.lua
deleted file mode 100644
index 9fbaa0427b..0000000000
--- a/applications/luci-olsr/luasrc/controller/olsr6.lua
+++ /dev/null
@@ -1,47 +0,0 @@
-module("luci.controller.olsr6", package.seeall)
-
-function index()
- if not nixio.fs.access("/etc/config/olsrd6") then
- return
- end
-
- require("luci.model.uci")
- local uci = luci.model.uci.cursor_state()
-
- local ol = entry(
- {"admin", "services", "olsrd6"},
- cbi("olsr/olsrd6"), "OLSR IPv6"
- )
- ol.subindex = true
-
- entry(
- {"admin", "services", "olsrd6", "iface"},
- cbi("olsr/olsrdiface6")
- ).leaf = true
-
- entry(
- {"admin", "services", "olsrd6", "hna"},
- cbi("olsr/olsrdhna6"), _("HNA6 Announcements")
- )
-
- oplg = entry(
- {"admin", "services", "olsrd6", "plugins"},
- cbi("olsr/olsrdplugins6"), _("Plugins")
- )
-
- oplg.leaf = true
- oplg.subindex = true
-
- local uci = require("luci.model.uci").cursor()
- uci:foreach("olsrd6", "LoadPlugin",
- function (section)
- local lib = section.library
- entry(
- {"admin", "services", "olsrd6", "plugins", lib },
- cbi("olsr/olsrdplugins6"),
- nil --'Plugin "%s"' % lib:gsub("^olsrd_",""):gsub("%.so.+$","")
- )
- end
- )
-end
-