summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-ntpc
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-07-17 21:01:15 +0000
committerSteven Barth <steven@midlink.org>2008-07-17 21:01:15 +0000
commitfce0b845018c80410fc315a8046588709ac2861e (patch)
tree5689e729d1046a349996baa5b0a1c828a3856fec /applications/luci-ntpc
parent43b995148183a350c8d8af0dd202ad9dcc9fd8c9 (diff)
Added new application luci-ntpc to luci-full and luci-mini
Diffstat (limited to 'applications/luci-ntpc')
-rw-r--r--applications/luci-ntpc/Makefile2
-rw-r--r--applications/luci-ntpc/luasrc/controller/ntpc.lua32
-rw-r--r--applications/luci-ntpc/luasrc/i18n/ntpc.de.lua5
-rw-r--r--applications/luci-ntpc/luasrc/i18n/ntpc.en.lua5
-rw-r--r--applications/luci-ntpc/luasrc/model/cbi/ntpc/ntpc.lua26
5 files changed, 70 insertions, 0 deletions
diff --git a/applications/luci-ntpc/Makefile b/applications/luci-ntpc/Makefile
new file mode 100644
index 000000000..81a96f6a8
--- /dev/null
+++ b/applications/luci-ntpc/Makefile
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk \ No newline at end of file
diff --git a/applications/luci-ntpc/luasrc/controller/ntpc.lua b/applications/luci-ntpc/luasrc/controller/ntpc.lua
new file mode 100644
index 000000000..2382f5297
--- /dev/null
+++ b/applications/luci-ntpc/luasrc/controller/ntpc.lua
@@ -0,0 +1,32 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+module("luci.controller.ntpc", package.seeall)
+
+function index()
+ require("luci.i18n")
+ luci.i18n.loadc("ntpc")
+ if not luci.fs.isfile("/etc/config/ntpclient") then
+ return
+ end
+
+ local page = entry({"admin", "system", "ntpc"}, cbi("ntpc/ntpc"), luci.i18n.translate("ntpc"), 50)
+ page.i18n = "ntpc"
+ page.dependent = true
+
+
+ local page = entry({"mini", "system", "ntpc"}, cbi("ntpc/ntpc"), luci.i18n.translate("ntpc"), 50)
+ page.i18n = "ntpc"
+ page.dependent = true
+end \ No newline at end of file
diff --git a/applications/luci-ntpc/luasrc/i18n/ntpc.de.lua b/applications/luci-ntpc/luasrc/i18n/ntpc.de.lua
new file mode 100644
index 000000000..4710414ad
--- /dev/null
+++ b/applications/luci-ntpc/luasrc/i18n/ntpc.de.lua
@@ -0,0 +1,5 @@
+ntpc = "Zeitsynchronisation"
+ntpc_desc = "Synchronisiert die Systemzeit über Internetzeitserver"
+ntpc_timeserver = "Zeitserver"
+ntpc_count = "Anzahl der Zeitmessungen"
+ntpc_count_desc = "0 = unendlich" \ No newline at end of file
diff --git a/applications/luci-ntpc/luasrc/i18n/ntpc.en.lua b/applications/luci-ntpc/luasrc/i18n/ntpc.en.lua
new file mode 100644
index 000000000..1baf3405d
--- /dev/null
+++ b/applications/luci-ntpc/luasrc/i18n/ntpc.en.lua
@@ -0,0 +1,5 @@
+ntpc = "Time Synchronisation"
+ntpc_desc = "Synchronizes the system time using internet time servers"
+ntpc_timeserver = "Time Server"
+ntpc_count = "Count of Time Measurements"
+ntpc_count_desc = "0 = infinite" \ No newline at end of file
diff --git a/applications/luci-ntpc/luasrc/model/cbi/ntpc/ntpc.lua b/applications/luci-ntpc/luasrc/model/cbi/ntpc/ntpc.lua
new file mode 100644
index 000000000..552c9861a
--- /dev/null
+++ b/applications/luci-ntpc/luasrc/model/cbi/ntpc/ntpc.lua
@@ -0,0 +1,26 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+m = Map("ntpclient", translate("ntpc"), translate("ntpc_desc"))
+
+s = m:section(TypedSection, "ntpclient", translate("ntpc_timeserver"))
+s.anonymous = true
+s.addremove = true
+s.template = "cbi/tblsection"
+
+s:option(Value, "hostname", translate("hostname"))
+s:option(Value, "port", translate("port")).rmempty = true
+s:option(Value, "count", translate("ntpc_count"), translate("ntpc_count_desc"))
+
+return m \ No newline at end of file