summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-mmc-over-gpio/luasrc/model
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-mmc-over-gpio/luasrc/model
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-mmc-over-gpio/luasrc/model')
-rw-r--r--applications/luci-mmc-over-gpio/luasrc/model/cbi/mmc_over_gpio.lua41
1 files changed, 0 insertions, 41 deletions
diff --git a/applications/luci-mmc-over-gpio/luasrc/model/cbi/mmc_over_gpio.lua b/applications/luci-mmc-over-gpio/luasrc/model/cbi/mmc_over_gpio.lua
deleted file mode 100644
index 04d356c193..0000000000
--- a/applications/luci-mmc-over-gpio/luasrc/model/cbi/mmc_over_gpio.lua
+++ /dev/null
@@ -1,41 +0,0 @@
---[[
-
-LuCI mmc_over_gpio
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
-m = Map("mmc_over_gpio", translate("MMC/SD driver configuration"),
- translate("MMC/SD driver configuration"))
-
-s = m:section(TypedSection, "mmc_over_gpio", translate("Settings"))
-s.addremove = true
-s.anonymous = true
-
-s:option(Flag, "enabled", translate("Enable"))
-
-s:option(Value, "name", translate("Name"))
-
-pin = s:option(Value, "DI_pin", translate("DI_pin"))
-for i = 0,7 do pin:value(i) end
-
-pin = s:option(Value, "DO_pin", translate("DO_pin"))
-for i = 0,7 do pin:value(i) end
-
-pin = s:option(Value, "CLK_pin", translate("CLK_pin"))
-for i = 0,7 do pin:value(i) end
-
-pin = s:option(Value, "CS_pin", translate("CS_pin"))
-for i = 0,7 do pin:value(i) end
-
-s:option(Value, "mode", translate("Mode"))
-
-return m