summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-ltqtapi
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-ltqtapi
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-ltqtapi')
-rw-r--r--applications/luci-ltqtapi/Makefile4
-rw-r--r--applications/luci-ltqtapi/luasrc/controller/ltqtapi.lua50
-rw-r--r--applications/luci-ltqtapi/luasrc/model/cbi/luci_ltqtapi/account.lua26
-rw-r--r--applications/luci-ltqtapi/luasrc/model/cbi/luci_ltqtapi/contact.lua30
-rw-r--r--applications/luci-ltqtapi/luasrc/view/admin_status/index/telephony.htm1
-rw-r--r--applications/luci-ltqtapi/luasrc/view/telephony_status.htm32
6 files changed, 0 insertions, 143 deletions
diff --git a/applications/luci-ltqtapi/Makefile b/applications/luci-ltqtapi/Makefile
deleted file mode 100644
index 77925c4e33..0000000000
--- a/applications/luci-ltqtapi/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-PO = telephony
-
-include ../../build/config.mk
-include ../../build/module.mk
diff --git a/applications/luci-ltqtapi/luasrc/controller/ltqtapi.lua b/applications/luci-ltqtapi/luasrc/controller/ltqtapi.lua
deleted file mode 100644
index abce09cea8..0000000000
--- a/applications/luci-ltqtapi/luasrc/controller/ltqtapi.lua
+++ /dev/null
@@ -1,50 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2019 John Crispin <blogic@openwrt.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-module("luci.controller.ltqtapi", package.seeall)
-
-function index()
- if not nixio.fs.access("/etc/config/telephony") then
- return
- end
-
- page = node("admin", "telephony")
- page.target = firstchild()
- page.title = _("VoIP")
- page.order = 90
-
- entry({"admin", "telephony", "account"}, cbi("luci_ltqtapi/account") , _("Account"), 10)
- entry({"admin", "telephony", "contact"}, cbi("luci_ltqtapi/contact") , _("Contacts"), 20)
-
- entry({"admin", "telephony", "status"}, call("tapi_status")).leaf = true
-end
-
-function tapi_status()
- local st = { }
- local state = require "luci.model.uci".cursor_state()
- state:load("telephony")
-
- st.status = "Offline";
- if state:get("telephony", "state", "port1", "0") == "0" then
- st.line1 = "Idle";
- else
- st.line1 = "Calling";
- end
- if state:get("telephony", "state", "port2", "0") == "0" then
- st.line2 = "Idle";
- else
- st.line2 = "Calling";
- end
- luci.http.prepare_content("application/json")
- luci.http.write_json(st)
-end
diff --git a/applications/luci-ltqtapi/luasrc/model/cbi/luci_ltqtapi/account.lua b/applications/luci-ltqtapi/luasrc/model/cbi/luci_ltqtapi/account.lua
deleted file mode 100644
index 40e00f346f..0000000000
--- a/applications/luci-ltqtapi/luasrc/model/cbi/luci_ltqtapi/account.lua
+++ /dev/null
@@ -1,26 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2010 John Crispin <blogic@openwrt.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-m = Map("telephony", translate("VoIP"))
-m.on_after_commit = function() luci.sys.call("/etc/init.d/telephony restart") end
-
-s = m:section(TypedSection, "account", translate("Account"), translate("Here You can specify the SIP account that you want to use."))
-s.anonymous = true
-s.addremove = true
-
-s:option(Value, "realm", translate("Realm"))
-s:option(Value, "username", translate("Username"))
-s:option(Value, "password", translate("Password"))
-s:option(Flag, "disabled", translate("Disabled"))
-
-return m
diff --git a/applications/luci-ltqtapi/luasrc/model/cbi/luci_ltqtapi/contact.lua b/applications/luci-ltqtapi/luasrc/model/cbi/luci_ltqtapi/contact.lua
deleted file mode 100644
index 08311b5152..0000000000
--- a/applications/luci-ltqtapi/luasrc/model/cbi/luci_ltqtapi/contact.lua
+++ /dev/null
@@ -1,30 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2010 John Crispin <blogic@openwrt.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-m = Map("telephony", translate("VoIP"))
-m.on_after_commit = function() luci.sys.call("/etc/init.d/telephony reload") end
-
-s = m:section(TypedSection, "contact", translate("Contact"), translate("Here You can specify the SIP contacts that you want to use."))
-s.anonymous = true
-s.addremove = true
-s.template = "cbi/tsection"
-
-s:option(Value, "desc", translate("Name"))
-s:option(Value, "code", translate("Shortdial"))
-s:option(Value, "dial", translate("Dial"))
-
-t = s:option(ListValue, "type", translate("Type"))
-t:value("sip", "SIP")
-t:value("realm", "Landline")
-
-return m
diff --git a/applications/luci-ltqtapi/luasrc/view/admin_status/index/telephony.htm b/applications/luci-ltqtapi/luasrc/view/admin_status/index/telephony.htm
deleted file mode 100644
index c7a58dd3ea..0000000000
--- a/applications/luci-ltqtapi/luasrc/view/admin_status/index/telephony.htm
+++ /dev/null
@@ -1 +0,0 @@
-<%+telephony_status%>
diff --git a/applications/luci-ltqtapi/luasrc/view/telephony_status.htm b/applications/luci-ltqtapi/luasrc/view/telephony_status.htm
deleted file mode 100644
index 234f909342..0000000000
--- a/applications/luci-ltqtapi/luasrc/view/telephony_status.htm
+++ /dev/null
@@ -1,32 +0,0 @@
-<script type="text/javascript">//<![CDATA[
-XHR.poll(5, '<%=luci.dispatcher.build_url("admin", "telephony", "status")%>', null,
- function(x, st)
- {
- var tb = document.getElementById('telephony_status_table');
- if (st && tb)
- {
- tb.deleteRow(1);
- var tr = tb.insertRow(-1);
- tr.className = 'cbi-section-table-row cbi-rowstyle-1';
-
- tr.insertCell(-1).innerHTML = st.status;
- tr.insertCell(-1).innerHTML = st.line1;
- tr.insertCell(-1).innerHTML = st.line2;
- }
- }
-);
-//]]></script>
-
-<fieldset class="cbi-section">
- <legend><%:Current Telephony State%></legend>
- <table class="cbi-section-table" id="telephony_status_table">
- <tr class="cbi-section-table-titles">
- <th class="cbi-section-table-cell"><%:Uplink%></th>
- <th class="cbi-section-table-cell"><%:Port1%></th>
- <th class="cbi-section-table-cell"><%:Port2%></th>
- </tr>
- <tr class="cbi-section-table-row">
- <td colspan="5"><em><br /><%:Collecting data...%></em></td>
- </tr>
- </table>
-</fieldset>