summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-hd-idle/luasrc
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-hd-idle/luasrc
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-hd-idle/luasrc')
-rw-r--r--applications/luci-hd-idle/luasrc/controller/hd_idle.lua27
-rw-r--r--applications/luci-hd-idle/luasrc/model/cbi/hd_idle.lua41
2 files changed, 0 insertions, 68 deletions
diff --git a/applications/luci-hd-idle/luasrc/controller/hd_idle.lua b/applications/luci-hd-idle/luasrc/controller/hd_idle.lua
deleted file mode 100644
index a6f4adc38..000000000
--- a/applications/luci-hd-idle/luasrc/controller/hd_idle.lua
+++ /dev/null
@@ -1,27 +0,0 @@
---[[
-
-LuCI hd-idle
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
-module("luci.controller.hd_idle", package.seeall)
-
-function index()
- if not nixio.fs.access("/etc/config/hd-idle") then
- return
- end
-
- local page
-
- page = entry({"admin", "services", "hd_idle"}, cbi("hd_idle"), _("hd-idle"), 60)
- page.dependent = true
-end
diff --git a/applications/luci-hd-idle/luasrc/model/cbi/hd_idle.lua b/applications/luci-hd-idle/luasrc/model/cbi/hd_idle.lua
deleted file mode 100644
index 0c844ca4e..000000000
--- a/applications/luci-hd-idle/luasrc/model/cbi/hd_idle.lua
+++ /dev/null
@@ -1,41 +0,0 @@
---[[
-
-LuCI hd-idle
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
-require("nixio.fs")
-
-m = Map("hd-idle", "hd-idle",
- translate("hd-idle is a utility program for spinning-down external " ..
- "disks after a period of idle time."))
-
-s = m:section(TypedSection, "hd-idle", translate("Settings"))
-s.anonymous = true
-
-s:option(Flag, "enabled", translate("Enable"))
-
-disk = s:option(Value, "disk", translate("Disk"))
-disk.rmempty = true
-for dev in nixio.fs.glob("/dev/[sh]d[a-z]") do
- disk:value(nixio.fs.basename(dev))
-end
-
-s:option(Value, "idle_time_interval", translate("Idle-time")).default = 10
-s.rmempty = true
-unit = s:option(ListValue, "idle_time_unit", translate("Idle-time unit"))
-unit.default = "minutes"
-unit:value("minutes", translate("min"))
-unit:value("hours", translate("h"))
-unit.rmempty = true
-
-return m