summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-freifunk-widgets/luasrc/model
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-freifunk-widgets/luasrc/model
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-freifunk-widgets/luasrc/model')
-rw-r--r--applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/heightwidth.lua26
-rw-r--r--applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/html.lua41
-rw-r--r--applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/iframe.lua23
-rw-r--r--applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/rssfeed.lua35
-rw-r--r--applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/search.lua25
-rw-r--r--applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/widget.lua48
-rw-r--r--applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/widgets_overview.lua75
7 files changed, 0 insertions, 273 deletions
diff --git a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/heightwidth.lua b/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/heightwidth.lua
deleted file mode 100644
index b572187bdd..0000000000
--- a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/heightwidth.lua
+++ /dev/null
@@ -1,26 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2012 Manuel Munz <freifunk at somakoma dot de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-local map, section = ...
-
-local width = wdg:option(Value, "width", translate("Width"))
-width.rmempty = true
-
---[[
-local height = wdg:option(Value, "height", translate("Height"))
-height.rmempty = true
-height.optional = true
-]]--
-
-local pr = wdg:option(Value, "paddingright", translate("Padding right"))
-pr.rmempty = true
diff --git a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/html.lua b/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/html.lua
deleted file mode 100644
index 367e8a269e..0000000000
--- a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/html.lua
+++ /dev/null
@@ -1,41 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2012 Manuel Munz <freifunk at somakoma dot de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-local map, section = ...
-local utl = require "luci.util"
-local fs = require "nixio.fs"
-local file = "/usr/share/customtext/" .. arg[1] .. ".html"
-
-local form, ferr = loadfile(utl.libpath() .. "/model/cbi/freifunk/widgets/heightwidth.lua")
-if form then
- setfenv(form, getfenv(1))(m, wdg)
-end
-
-t = wdg:option(TextValue, "_text")
-t.rmempty = true
-t.rows = 20
-
-
-function t.cfgvalue()
- return fs.readfile(file) or ""
-end
-
-function t.write(self, section, value)
- return fs.writefile(file, value)
-end
-
-function t.remove(self, section)
- return fs.unlink(file)
-end
-
-
diff --git a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/iframe.lua b/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/iframe.lua
deleted file mode 100644
index b9cbcaee56..0000000000
--- a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/iframe.lua
+++ /dev/null
@@ -1,23 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2012 Manuel Munz <freifunk at somakoma dot de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-local map, section = ...
-local utl = require "luci.util"
-
-local form, ferr = loadfile(utl.libpath() .. "/model/cbi/freifunk/widgets/heightwidth.lua")
-if form then
- setfenv(form, getfenv(1))(m, wdg)
-end
-
-local url = wdg:option(Value, "url", translate("URL"))
-url.default = "http://www.freifunk.net"
diff --git a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/rssfeed.lua b/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/rssfeed.lua
deleted file mode 100644
index 5df5a346fe..0000000000
--- a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/rssfeed.lua
+++ /dev/null
@@ -1,35 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2012 Manuel Munz <freifunk at somakoma dot de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-local map, section = ...
-local utl = require "luci.util"
-
-local form, ferr = loadfile(utl.libpath() .. "/model/cbi/freifunk/widgets/heightwidth.lua")
-if form then
- setfenv(form, getfenv(1))(m, wdg)
-end
-
-local url = wdg:option(Value, "url", translate("URL"))
-url.default = "http://global.freifunk.net/rss/all/rss.xml"
-
-local max = wdg:option(Value, "max", translate("Maximal entries to show"))
-max.rmempty = true
-max.default = "10"
-max.datatype = "integer"
-
-local cache = wdg:option(Value, "cache", translate("Cache Time"), translate("Cache downloaded feed for that many seconds."))
-cache.rmempty = true
-cache.default = "3600"
-cache.datatype = "integer"
-
-
diff --git a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/search.lua b/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/search.lua
deleted file mode 100644
index 735dc7cdff..0000000000
--- a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/search.lua
+++ /dev/null
@@ -1,25 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2012 Manuel Munz <freifunk at somakoma dot de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-local map, section = ...
-local utl = require "luci.util"
-
-local form, ferr = loadfile(utl.libpath() .. "/model/cbi/freifunk/widgets/heightwidth.lua")
-if form then
- setfenv(form, getfenv(1))(m, wdg)
-end
-
-local engine = wdg:option(DynamicList, "engine", translate("Search Engine"),
- translate("Use the form Name|URL, where URL must be a full URL to the search engine " ..
- "including the query GET parameter, e.g. 'Google|http://www.google.de/search?q='")
- )
diff --git a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/widget.lua b/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/widget.lua
deleted file mode 100644
index 5adfc8f850..0000000000
--- a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/widget.lua
+++ /dev/null
@@ -1,48 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2012 Manuel Munz <freifunk at somakoma dot de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-
-local uci = require "luci.model.uci".cursor()
-local dsp = require "luci.dispatcher"
-local utl = require "luci.util"
-local widget = uci:get("freifunk-widgets", arg[1], "template")
-local title = uci:get("freifunk-widgets", arg[1], "title") or ""
-
-m = Map("freifunk-widgets", translate("Widget"))
-m.redirect = luci.dispatcher.build_url("admin/freifunk/widgets")
-
-if not arg[1] or m.uci:get("freifunk-widgets", arg[1]) ~= "widget" then
- luci.http.redirect(m.redirect)
- return
-end
-
-wdg = m:section(NamedSection, arg[1], "widget", translate("Widget") .. " " .. title)
-wdg.anonymous = true
-wdg.addremove = false
-
-local en = wdg:option(Flag, "enabled", translate("Enable"))
-en.rmempty = false
-
-local title = wdg:option(Value, "title", translate("Title"))
-title.rmempty = true
-
-local form = loadfile(
- utl.libpath() .. "/model/cbi/freifunk/widgets/%s.lua" % widget
-)
-
-if form then
- setfenv(form, getfenv(1))(m, wdg)
-end
-
-return m
-
diff --git a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/widgets_overview.lua b/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/widgets_overview.lua
deleted file mode 100644
index 50771d7e0d..0000000000
--- a/applications/luci-freifunk-widgets/luasrc/model/cbi/freifunk/widgets/widgets_overview.lua
+++ /dev/null
@@ -1,75 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2012 Manuel Munz <freifunk at somakoma dot de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-]]--
-
-local uci = require "luci.model.uci".cursor()
-local fs = require "luci.fs"
-local utl = require "luci.util"
-m = Map("freifunk-widgets", translate("Widgets"),
- translate("Configure installed widgets."))
-
-wdg = m:section(TypedSection, "widget", translate("Widgets"))
-wdg.addremove = true
-wdg.extedit = luci.dispatcher.build_url("admin/freifunk/widgets/widget/%s")
-wdg.template = "cbi/tblsection"
-wdg.sortable = true
-
---[[
-function wdg.create(...)
- local sid = TypedSection.create(...)
- luci.http.redirect(wdg.extedit % sid)
-end
-]]--
-
-local en = wdg:option(Flag, "enabled", translate("Enable"))
-en.rmempty = false
---en.default = "0"
-function en.cfgvalue(self, section)
- return Flag.cfgvalue(self, section) or "0"
-end
-
-local tmpl = wdg:option(ListValue, "template", translate("Template"))
-for k, v in ipairs(fs.dir('/usr/lib/lua/luci/view/freifunk/widgets/')) do
- if v ~= "." and v ~= ".." then
- tmpl:value(v)
- end
-end
-
-local title = wdg:option(Value, "title", translate("Title"))
-title.rmempty = true
-
-local width = wdg:option(Value, "width", translate("Width"))
-width.rmempty = true
-
-local height = wdg:option(Value, "height", translate("Height"))
-height.rmempty = true
-
-local pr = wdg:option(Value, "paddingright", translate("Padding right"))
-pr.rmempty = true
-
-function m.on_commit(self)
- -- clean custom text files whose config has been deleted
- local dir = "/usr/share/customtext/"
- local active = {}
- uci:foreach("freifunk-widgets", "widget", function(s)
- if s["template"] == "html" then
- table.insert(active, s[".name"])
- end
- end )
- for k, v in ipairs(fs.dir(dir)) do
- filename = string.gsub(v, ".html", "")
- if not utl.contains(active, filename) then
- fs.unlink(dir .. v)
- end
- end
-end
-
-return m