summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-freifunk-diagnostics/luasrc/controller
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-freifunk-diagnostics/luasrc/controller
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-freifunk-diagnostics/luasrc/controller')
-rw-r--r--applications/luci-freifunk-diagnostics/luasrc/controller/freifunk/diag.lua82
1 files changed, 0 insertions, 82 deletions
diff --git a/applications/luci-freifunk-diagnostics/luasrc/controller/freifunk/diag.lua b/applications/luci-freifunk-diagnostics/luasrc/controller/freifunk/diag.lua
deleted file mode 100644
index 2a5db6751a..0000000000
--- a/applications/luci-freifunk-diagnostics/luasrc/controller/freifunk/diag.lua
+++ /dev/null
@@ -1,82 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2008 Steven Barth <steven@midlink.org>
-Copyright 2011 Jo-Philipp Wich <xm@subsignal.org>
-Copyright 2013 Manuel Munz <freifunk@somakoma.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-module("luci.controller.freifunk.diag", package.seeall)
-
-function index()
- local uci = require("luci.model.uci").cursor()
- local page
- page = node("freifunk", "status", "diagnostics")
- page.target = template("freifunk/diagnostics")
- page.title = _("Diagnostics")
- page.order = 60
-
- page = entry({"freifunk", "status", "diag_ping"}, call("diag_ping"), nil)
- page.leaf = true
-
- page = entry({"freifunk", "status", "diag_nslookup"}, call("diag_nslookup"), nil)
- page.leaf = true
-
- page = entry({"freifunk", "status", "diag_traceroute"}, call("diag_traceroute"), nil)
- page.leaf = true
-
- page = entry({"freifunk", "status", "diag_ping6"}, call("diag_ping6"), nil)
- page.leaf = true
-
- page = entry({"freifunk", "status", "diag_traceroute6"}, call("diag_traceroute6"), nil)
- page.leaf = true
-end
-
-function diag_command(cmd, addr)
- if addr and addr:match("^[a-zA-Z0-9%-%.:_]+$") then
- luci.http.prepare_content("text/plain")
-
- local util = io.popen(cmd % addr)
- if util then
- while true do
- local ln = util:read("*l")
- if not ln then break end
- luci.http.write(ln)
- luci.http.write("\n")
- end
-
- util:close()
- end
-
- return
- end
-
- luci.http.status(500, "Bad address")
-end
-
-function diag_ping(addr)
- diag_command("ping -c 5 -W 1 %q 2>&1", addr)
-end
-
-function diag_traceroute(addr)
- diag_command("traceroute -q 1 -w 1 -n %q 2>&1", addr)
-end
-
-function diag_nslookup(addr)
- diag_command("nslookup %q 2>&1", addr)
-end
-
-function diag_ping6(addr)
- diag_command("ping6 -c 5 %q 2>&1", addr)
-end
-
-function diag_traceroute6(addr)
- diag_command("traceroute6 -q 1 -w 2 -n %q 2>&1", addr)
-end