summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-commands/luasrc/model
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-commands/luasrc/model
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-commands/luasrc/model')
-rw-r--r--applications/luci-commands/luasrc/model/cbi/commands.lua37
1 files changed, 0 insertions, 37 deletions
diff --git a/applications/luci-commands/luasrc/model/cbi/commands.lua b/applications/luci-commands/luasrc/model/cbi/commands.lua
deleted file mode 100644
index 1359eb2acd..0000000000
--- a/applications/luci-commands/luasrc/model/cbi/commands.lua
+++ /dev/null
@@ -1,37 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2012 Jo-Philipp Wich <jow@openwrt.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-local m, s
-
-m = Map("luci", translate("Custom Commands"),
- translate("This page allows you to configure custom shell commands which can be easily invoked from the web interface."))
-
-s = m:section(TypedSection, "command", "")
-s.template = "cbi/tblsection"
-s.anonymous = true
-s.addremove = true
-
-
-s:option(Value, "name", translate("Description"),
- translate("A short textual description of the configured command"))
-
-s:option(Value, "command", translate("Command"),
- translate("Command line to execute"))
-
-s:option(Flag, "param", translate("Custom arguments"),
- translate("Allow the user to provide additional command line arguments"))
-
-s:option(Flag, "public", translate("Public access"),
- translate("Allow executing the command and downloading its output without prior authentication"))
-
-return m