summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-wshaper/luasrc
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-wshaper/luasrc
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-wshaper/luasrc')
-rw-r--r--applications/luci-app-wshaper/luasrc/controller/wshaper.lua19
-rw-r--r--applications/luci-app-wshaper/luasrc/model/cbi/wshaper.lua55
2 files changed, 74 insertions, 0 deletions
diff --git a/applications/luci-app-wshaper/luasrc/controller/wshaper.lua b/applications/luci-app-wshaper/luasrc/controller/wshaper.lua
new file mode 100644
index 000000000..9d7f01e9d
--- /dev/null
+++ b/applications/luci-app-wshaper/luasrc/controller/wshaper.lua
@@ -0,0 +1,19 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2011 Manuel Munz <freifunk somakoma de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+
+module "luci.controller.wshaper"
+
+function index()
+ entry({"admin", "network", "wshaper"}, cbi("wshaper"), _("Wondershaper"), 80)
+end
+
diff --git a/applications/luci-app-wshaper/luasrc/model/cbi/wshaper.lua b/applications/luci-app-wshaper/luasrc/model/cbi/wshaper.lua
new file mode 100644
index 000000000..faa64f66d
--- /dev/null
+++ b/applications/luci-app-wshaper/luasrc/model/cbi/wshaper.lua
@@ -0,0 +1,55 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2011 Manuel Munz <freifunk at somakoma dot de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+]]--
+
+require("luci.tools.webadmin")
+
+m = Map("wshaper", translate("Wondershaper"),
+ translate("Wondershaper shapes traffic to ensure low latencies for interactive traffic even when your " ..
+ "internet connection is highly saturated."))
+
+s = m:section(NamedSection, "settings", "wshaper", translate("Wondershaper settings"))
+s.anonymous = true
+
+network = s:option(ListValue, "network", translate("Interface"))
+luci.tools.webadmin.cbi_add_networks(network)
+
+uplink = s:option(Value, "uplink", translate("Uplink"), translate("Upstream bandwidth in kbit/s"))
+uplink.optional = false
+uplink.datatype = "uinteger"
+uplink.default = "240"
+
+uplink = s:option(Value, "downlink", translate("Downlink"), translate("Downstream bandwidth in kbit/s"))
+uplink.optional = false
+uplink.datatype = "uinteger"
+uplink.default = "200"
+
+nopriohostsrc = s:option(DynamicList, "nopriohostsrc", translate("Low priority hosts (Source)"), translate("Host or Network in CIDR notation."))
+nopriohostsrc.optional = true
+nopriohostsrc.datatype = ipaddr
+nopriohostsrc.placeholder = "10.0.0.1/32"
+
+nopriohostdst = s:option(DynamicList, "nopriohostdst", translate("Low priority hosts (Destination)"), translate("Host or Network in CIDR notation."))
+nopriohostdst.optional = true
+nopriohostdst.datatype = ipaddr
+nopriohostdst.placeholder = "10.0.0.1/32"
+
+noprioportsrc = s:option(DynamicList, "noprioportsrc", translate("Low priority source ports"))
+noprioportsrc.optional = true
+noprioportsrc.datatype = "range(0,65535)"
+noprioportsrc.placeholder = "21"
+
+noprioportdst = s:option(DynamicList, "noprioportdst", translate("Low priority destination ports"))
+noprioportdst.optional = true
+noprioportdst.datatype = "range(0,65535)"
+noprioportdst.placeholder = "21"
+
+return m