summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-wol/luasrc/controller/wol.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-wol/luasrc/controller/wol.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-wol/luasrc/controller/wol.lua')
-rw-r--r--applications/luci-app-wol/luasrc/controller/wol.lua6
1 files changed, 6 insertions, 0 deletions
diff --git a/applications/luci-app-wol/luasrc/controller/wol.lua b/applications/luci-app-wol/luasrc/controller/wol.lua
new file mode 100644
index 0000000000..73a9594b2a
--- /dev/null
+++ b/applications/luci-app-wol/luasrc/controller/wol.lua
@@ -0,0 +1,6 @@
+module("luci.controller.wol", package.seeall)
+
+function index()
+ entry({"admin", "network", "wol"}, cbi("wol"), _("Wake on LAN"), 90)
+ entry({"mini", "network", "wol"}, cbi("wol"), _("Wake on LAN"), 90)
+end