summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-wifischedule/Makefile
diff options
context:
space:
mode:
authorNils Koenig <mail_openwrtdev@newk.it>2016-11-12 17:22:18 +0100
committerNils Koenig <mail_openwrtdev@newk.it>2016-11-25 16:17:55 +0100
commit222bf48b741680f10b265274c906f684140b42fe (patch)
treeab78342fd9840f07bec4ea8dd5c103e52b90a2f2 /applications/luci-app-wifischedule/Makefile
parentd7d97723fef1c4e5fe436b15e088d24d558246b3 (diff)
luci-app-wifischedule: added package
Turns WiFi on and off according to a schedule Splitted frontend and backend in different packages. This feature has now a dependency to the package wifischedule in openwrt/packages/net which needs to be merged as well. Signed-off-by: Nils Koenig <openwrt@newk.it>
Diffstat (limited to 'applications/luci-app-wifischedule/Makefile')
-rw-r--r--applications/luci-app-wifischedule/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/applications/luci-app-wifischedule/Makefile b/applications/luci-app-wifischedule/Makefile
new file mode 100644
index 000000000..1708562a4
--- /dev/null
+++ b/applications/luci-app-wifischedule/Makefile
@@ -0,0 +1,22 @@
+# Copyright (c) 2016, prpl Foundation
+#
+# Permission to use, copy, modify, and/or distribute this software for any purpose with or without
+# fee is hereby granted, provided that the above copyright notice and this permission notice appear
+# in all copies.
+#
+# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE
+# FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM
+# LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION,
+# ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+#
+# Author: Nils Koenig <openwrt@newk.it>
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=Turns WiFi on and off according to a schedule
+LUCI_DEPENDS:=+wifischedule
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature