summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-vpnbypass/Makefile
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.net>2017-01-28 07:38:05 -0800
committerStan Grishin <stangri@melmac.net>2017-01-28 08:42:29 -0800
commitd2fcd543a43dcea1324a5456a171340271693cca (patch)
tree013ff3c7c3adc12acbe81024dce565e2b8e2e2ac /applications/luci-app-vpnbypass/Makefile
parentc9c76a136af2c7a1936655e667b9949862dc4842 (diff)
luci-app-vpnbypass: switch to luci-tree Makefile, i18n support
Signed-off-by: Stan Grishin <stangri@melmac.net> luci-app-vpnbypass: fixed makefile, fixed pot-file Signed-off-by: Stan Grishin <stangri@melmac.net>
Diffstat (limited to 'applications/luci-app-vpnbypass/Makefile')
-rw-r--r--applications/luci-app-vpnbypass/Makefile39
1 files changed, 6 insertions, 33 deletions
diff --git a/applications/luci-app-vpnbypass/Makefile b/applications/luci-app-vpnbypass/Makefile
index 58b3d30d9..5f63dcee7 100644
--- a/applications/luci-app-vpnbypass/Makefile
+++ b/applications/luci-app-vpnbypass/Makefile
@@ -3,42 +3,15 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=luci-app-vpnbypass
PKG_VERSION:=1.0.0
-PKG_RELEASE:=3
+PKG_RELEASE:=5
PKG_LICENSE:=GPL-3.0+
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-include $(INCLUDE_DIR)/package.mk
+LUCI_TITLE:=VPN Bypass Web UI
+LUCI_DEPENDS:=+vpnbypass
+LUCI_PKGARCH:=all
-define Package/luci-app-vpnbypass
- SECTION:=luci
- CATEGORY:=LuCI
- SUBMENU:=3. Applications
- TITLE:=VPN Bypass Web UI
- DEPENDS:=+luci-mod-admin-full +vpnbypass
- PKGARCH:=all
-endef
+include ../../luci.mk
-define Package/luci-app-vpnbypass/description
- This package will install VPN Bypass Web UI.
-endef
-
-define Build/Prepare
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/luci-app-vpnbypass/install
- $(INSTALL_DIR) $(1)/usr/lib/lua/luci/controller/
- $(INSTALL_BIN) ./luasrc/controller/vpnbypass.lua $(1)/usr/lib/lua/luci/controller/vpnbypass.lua
- $(INSTALL_DIR) $(1)/usr/lib/lua/luci/model/cbi/
- $(INSTALL_BIN) ./luasrc/model/cbi/vpnbypass.lua $(1)/usr/lib/lua/luci/model/cbi/vpnbypass.lua
-endef
-
-$(eval $(call BuildPackage,luci-app-vpnbypass)) \ No newline at end of file
+# call BuildPackage - OpenWrt buildroot signature \ No newline at end of file