summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-vpnbypass/Makefile
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.net>2017-01-26 14:54:48 -0800
committerStan Grishin <stangri@melmac.net>2017-01-26 14:54:48 -0800
commitc9c76a136af2c7a1936655e667b9949862dc4842 (patch)
tree4176cc0634812b8923d02227515f349ddd3648be /applications/luci-app-vpnbypass/Makefile
parenta7c5c018b6782f4160410981c723c82db9762ff7 (diff)
luci-app-vpnbypass: initial commit of companion app to vpnbypass package
Signed-off-by: Stan Grishin <stangri@melmac.net>
Diffstat (limited to 'applications/luci-app-vpnbypass/Makefile')
-rw-r--r--applications/luci-app-vpnbypass/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/applications/luci-app-vpnbypass/Makefile b/applications/luci-app-vpnbypass/Makefile
new file mode 100644
index 000000000..58b3d30d9
--- /dev/null
+++ b/applications/luci-app-vpnbypass/Makefile
@@ -0,0 +1,44 @@
+# Copyright (c) 2017 Stan Grishin (stangri@melmac.net)
+# This is free software, licensed under the GNU General Public License v3.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=luci-app-vpnbypass
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=3
+PKG_LICENSE:=GPL-3.0+
+PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/luci-app-vpnbypass
+ SECTION:=luci
+ CATEGORY:=LuCI
+ SUBMENU:=3. Applications
+ TITLE:=VPN Bypass Web UI
+ DEPENDS:=+luci-mod-admin-full +vpnbypass
+ PKGARCH:=all
+endef
+
+define Package/luci-app-vpnbypass/description
+ This package will install VPN Bypass Web UI.
+endef
+
+define Build/Prepare
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/luci-app-vpnbypass/install
+ $(INSTALL_DIR) $(1)/usr/lib/lua/luci/controller/
+ $(INSTALL_BIN) ./luasrc/controller/vpnbypass.lua $(1)/usr/lib/lua/luci/controller/vpnbypass.lua
+ $(INSTALL_DIR) $(1)/usr/lib/lua/luci/model/cbi/
+ $(INSTALL_BIN) ./luasrc/model/cbi/vpnbypass.lua $(1)/usr/lib/lua/luci/model/cbi/vpnbypass.lua
+endef
+
+$(eval $(call BuildPackage,luci-app-vpnbypass)) \ No newline at end of file