summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-voice-core/luasrc
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-voice-core/luasrc
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-voice-core/luasrc')
-rw-r--r--applications/luci-app-voice-core/luasrc/controller/luci_voice.lua31
-rw-r--r--applications/luci-app-voice-core/luasrc/view/luci_voice/index.htm24
-rw-r--r--applications/luci-app-voice-core/luasrc/view/luci_voice/phone_index.htm20
3 files changed, 75 insertions, 0 deletions
diff --git a/applications/luci-app-voice-core/luasrc/controller/luci_voice.lua b/applications/luci-app-voice-core/luasrc/controller/luci_voice.lua
new file mode 100644
index 000000000..728afb6a4
--- /dev/null
+++ b/applications/luci-app-voice-core/luasrc/controller/luci_voice.lua
@@ -0,0 +1,31 @@
+--[[
+
+Luci Voice Core
+(c) 2009 Daniel Dickinson
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+
+module("luci.controller.luci_voice", package.seeall)
+
+function index()
+ local e
+
+ e = entry({"admin", "voice"}, template("luci_voice/index") , _("Voice"), 90)
+ e.index = true
+
+ e = entry({"mini", "voice"}, template("luci_voice/index"), _("Voice"), 90)
+ e.index = true
+
+ e = entry({"mini", "voice", "phones"}, template("luci_voice/phone_index"), _("Phones"), 90)
+ e.index = true
+
+ e = entry({"admin", "voice", "phones"}, template("luci_voice/phone_index"), _("Phones"), 90)
+ e.index = true
+
+end
diff --git a/applications/luci-app-voice-core/luasrc/view/luci_voice/index.htm b/applications/luci-app-voice-core/luasrc/view/luci_voice/index.htm
new file mode 100644
index 000000000..73d2ce446
--- /dev/null
+++ b/applications/luci-app-voice-core/luasrc/view/luci_voice/index.htm
@@ -0,0 +1,24 @@
+<%#
+LuCI - Lua Configuration Interface
+(c) 2009 Daniel Dickinson
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+-%>
+<%+header%>
+<h2><a id="content" name="content">Voice</a></h2>
+<p>Here you can control OpenWRT voice-related settings and see
+ voice-related information from OpenWRT</p>
+<p>In particular Asterisk configuration and information is displayed
+ here, as well as diagnostics that specifically apply to voice but are
+ not general networking diagnostics (e.g. includes SIP device scans, but not
+ ping tests). Includes PSTN phones as well as VoIP and possibly
+ non-telephony related options.
+</p>
+<%+footer%>
diff --git a/applications/luci-app-voice-core/luasrc/view/luci_voice/phone_index.htm b/applications/luci-app-voice-core/luasrc/view/luci_voice/phone_index.htm
new file mode 100644
index 000000000..89b866114
--- /dev/null
+++ b/applications/luci-app-voice-core/luasrc/view/luci_voice/phone_index.htm
@@ -0,0 +1,20 @@
+<%#
+LuCI - Lua Configuration Interface
+(c) 2009 Daniel Dickinson
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+-%>
+<%+header%>
+<h2><a id="content" name="content">Phones</a></h2>
+<p>Here you can control phone configuration and information in OpenWRT</p>
+<p>You can control the setup of phone clients and servers and see
+ information such as diagnostics related to phone devices from this menu.
+</p>
+<%+footer%>