summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-vnstat/luasrc/view/vnstat.htm
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-vnstat/luasrc/view/vnstat.htm
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-vnstat/luasrc/view/vnstat.htm')
-rw-r--r--applications/luci-app-vnstat/luasrc/view/vnstat.htm108
1 files changed, 108 insertions, 0 deletions
diff --git a/applications/luci-app-vnstat/luasrc/view/vnstat.htm b/applications/luci-app-vnstat/luasrc/view/vnstat.htm
new file mode 100644
index 000000000..d67f9b3be
--- /dev/null
+++ b/applications/luci-app-vnstat/luasrc/view/vnstat.htm
@@ -0,0 +1,108 @@
+<%#
+LuCI - Lua Configuration Interface
+Copyright 2010 Jo-Philipp Wich <xm@subsignal.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+-%>
+
+<%-
+
+local fs = require "nixio.fs"
+local sys = require "luci.sys"
+local utl = require "luci.util"
+
+local param = luci.http.formvalue
+
+local iface = param("iface")
+local style = param("style")
+
+style = (style and #style > 0) and style or "s"
+
+
+--
+-- render image
+--
+if iface then
+ style = style:gsub("[^%w]", "")
+ iface = iface:gsub("[^%w%.%-]", "")
+
+ luci.http.prepare_content("image/png")
+
+ local png = io.popen("vnstati -i '%s' '-%s' -o -" % { iface, style })
+ luci.http.write(png:read("*a"))
+ png:close()
+
+ return
+
+--
+-- update database
+--
+else
+ sys.call("vnstat -u >/dev/null 2>/dev/null")
+end
+
+
+--
+-- find databases
+--
+local dbdir, line
+
+for line in io.lines("/etc/vnstat.conf") do
+ dbdir = line:match("^%s*DatabaseDir%s+[\"'](%S-)[\"']")
+ if dbdir then break end
+end
+
+dbdir = dbdir or "/var/lib/vnstat"
+
+-%>
+
+<%+header%>
+
+<h2><a id="content" name="content"><%:VnStat Graphs%></a></h2>
+
+<form action="" method="get">
+
+<select name="style">
+ <option value="s"<%=(style == "s") and ' selected="selected"' or ''%>><%:Summary display%></option>
+ <option value="t"<%=(style == "t") and ' selected="selected"' or ''%>><%:Top 10 display%></option>
+ <option value="h"<%=(style == "h") and ' selected="selected"' or ''%>><%:Hourly traffic%></option>
+ <option value="d"<%=(style == "d") and ' selected="selected"' or ''%>><%:Daily traffic%></option>
+ <option value="m"<%=(style == "m") and ' selected="selected"' or ''%>><%:Monthly traffic%></option>
+</select>
+
+<input type="submit" value="<%:Update ยป%>" />
+
+</form>
+
+<br /><hr /><br />
+
+<div style="text-align:center">
+<%
+ empty = true
+ ifdir = fs.dir(dbdir)
+
+ if ifdir then
+ for iface in ifdir do
+ if iface:sub(1,1) ~= "." then
+ empty = false
+%>
+ <img src="<%=REQUEST_URI%>?iface=<%=iface%>&amp;style=<%=param('style')%>" alt="" />
+ <br /><br />
+<%
+ end
+ end
+ end
+%>
+
+<% if empty then %>
+<p><em><%:No database has been set up yet. Go to the VnStat configuration and enable monitoring for one or more interfaces.%></em></p>
+<% end %>
+
+</div>
+
+<%+footer%>