summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-vnstat/luasrc/controller
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-vnstat/luasrc/controller
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-vnstat/luasrc/controller')
-rw-r--r--applications/luci-app-vnstat/luasrc/controller/vnstat.lua11
1 files changed, 11 insertions, 0 deletions
diff --git a/applications/luci-app-vnstat/luasrc/controller/vnstat.lua b/applications/luci-app-vnstat/luasrc/controller/vnstat.lua
new file mode 100644
index 000000000..3871fa254
--- /dev/null
+++ b/applications/luci-app-vnstat/luasrc/controller/vnstat.lua
@@ -0,0 +1,11 @@
+module("luci.controller.vnstat", package.seeall)
+
+function index()
+ entry({"admin", "status", "vnstat"}, alias("admin", "status", "vnstat", "graphs"), _("VnStat Traffic Monitor"), 90)
+ entry({"admin", "status", "vnstat", "graphs"}, template("vnstat"), _("Graphs"), 1)
+ entry({"admin", "status", "vnstat", "config"}, cbi("vnstat"), _("Configuration"), 2)
+
+ entry({"mini", "network", "vnstat"}, alias("mini", "network", "vnstat", "graphs"), _("VnStat Traffic Monitor"), 90)
+ entry({"mini", "network", "vnstat", "graphs"}, template("vnstat"), _("Graphs"), 1)
+ entry({"mini", "network", "vnstat", "config"}, cbi("vnstat"), _("Configuration"), 2)
+end