summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-ushare/root/etc/uci-defaults/luci-ushare
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-ushare/root/etc/uci-defaults/luci-ushare
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-ushare/root/etc/uci-defaults/luci-ushare')
-rwxr-xr-xapplications/luci-app-ushare/root/etc/uci-defaults/luci-ushare11
1 files changed, 11 insertions, 0 deletions
diff --git a/applications/luci-app-ushare/root/etc/uci-defaults/luci-ushare b/applications/luci-app-ushare/root/etc/uci-defaults/luci-ushare
new file mode 100755
index 000000000..8bcb6e411
--- /dev/null
+++ b/applications/luci-app-ushare/root/etc/uci-defaults/luci-ushare
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+uci -q batch <<-EOF >/dev/null
+ delete ucitrack.@ushare[-1]
+ add ucitrack ushare
+ set ucitrack.@ushare[-1].init=ushare
+ commit ucitrack
+EOF
+
+rm -f /tmp/luci-indexcache
+exit 0