summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-ushare/luasrc
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-ushare/luasrc
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-ushare/luasrc')
-rw-r--r--applications/luci-app-ushare/luasrc/controller/ushare.lua27
-rw-r--r--applications/luci-app-ushare/luasrc/model/cbi/ushare.lua42
2 files changed, 69 insertions, 0 deletions
diff --git a/applications/luci-app-ushare/luasrc/controller/ushare.lua b/applications/luci-app-ushare/luasrc/controller/ushare.lua
new file mode 100644
index 0000000000..eed853239b
--- /dev/null
+++ b/applications/luci-app-ushare/luasrc/controller/ushare.lua
@@ -0,0 +1,27 @@
+--[[
+
+LuCI uShare
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+module("luci.controller.ushare", package.seeall)
+
+function index()
+ if not nixio.fs.access("/etc/config/ushare") then
+ return
+ end
+
+ local page
+
+ page = entry({"admin", "services", "ushare"}, cbi("ushare"), _("uShare"), 60)
+ page.dependent = true
+end
diff --git a/applications/luci-app-ushare/luasrc/model/cbi/ushare.lua b/applications/luci-app-ushare/luasrc/model/cbi/ushare.lua
new file mode 100644
index 0000000000..7032b2d5ce
--- /dev/null
+++ b/applications/luci-app-ushare/luasrc/model/cbi/ushare.lua
@@ -0,0 +1,42 @@
+--[[
+
+LuCI uShare
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+m = Map("ushare", translate("uShare"),
+ luci.util.pcdata(translate("uShare is a UPnP (TM) A/V & DLNA Media Server. It implements the server component that provides UPnP media devices with information on available multimedia files.")))
+
+s = m:section(TypedSection, "ushare", translate("Settings"))
+s.addremove = false
+s.anonymous = true
+
+s:option(Flag, "enabled", translate("Enable"))
+
+s:option(Value, "username", translate("Username"))
+
+s:option(Value, "servername", translate("Servername"))
+
+dif = s:option( Value, "interface", translate("Interface"))
+for _, nif in ipairs(luci.sys.net.devices()) do
+ if nif ~= "lo" then dif:value(nif) end
+end
+
+s:option(DynamicList, "content_directories", translate("Content directories"))
+
+s:option(Flag, "disable_webif", translate("Disable webinterface"))
+
+s:option(Flag, "disable_telnet", translate("Disable telnet console"))
+
+s:option(Value, "options", translate("Options"))
+
+return m