summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-upnp/luasrc/view
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-upnp/luasrc/view
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-upnp/luasrc/view')
-rw-r--r--applications/luci-app-upnp/luasrc/view/admin_status/index/upnp.htm1
-rw-r--r--applications/luci-app-upnp/luasrc/view/upnp_status.htm67
2 files changed, 68 insertions, 0 deletions
diff --git a/applications/luci-app-upnp/luasrc/view/admin_status/index/upnp.htm b/applications/luci-app-upnp/luasrc/view/admin_status/index/upnp.htm
new file mode 100644
index 0000000000..d0c2e2ed50
--- /dev/null
+++ b/applications/luci-app-upnp/luasrc/view/admin_status/index/upnp.htm
@@ -0,0 +1 @@
+<%+upnp_status%>
diff --git a/applications/luci-app-upnp/luasrc/view/upnp_status.htm b/applications/luci-app-upnp/luasrc/view/upnp_status.htm
new file mode 100644
index 0000000000..d50ed0c4d7
--- /dev/null
+++ b/applications/luci-app-upnp/luasrc/view/upnp_status.htm
@@ -0,0 +1,67 @@
+<script type="text/javascript">//<![CDATA[
+ function upnp_delete_fwd(idx) {
+ XHR.get('<%=luci.dispatcher.build_url("admin", "services", "upnp", "delete")%>/' + idx, null,
+ function(x)
+ {
+ var tb = document.getElementById('upnp_status_table');
+ if (tb && (idx < tb.rows.length))
+ tb.rows[0].parentNode.removeChild(tb.rows[idx]);
+ }
+ );
+ }
+
+ XHR.poll(5, '<%=luci.dispatcher.build_url("admin", "services", "upnp", "status")%>', null,
+ function(x, st)
+ {
+ var tb = document.getElementById('upnp_status_table');
+ if (st && tb)
+ {
+ /* clear all rows */
+ while( tb.rows.length > 1 )
+ tb.deleteRow(1);
+
+ for( var i = 0; i < st.length; i++ )
+ {
+ var tr = tb.insertRow(-1);
+ tr.className = 'cbi-section-table-row cbi-rowstyle-' + ((i % 2) + 1);
+
+ tr.insertCell(-1).innerHTML = st[i].proto;
+ tr.insertCell(-1).innerHTML = st[i].extport;
+ tr.insertCell(-1).innerHTML = st[i].intaddr;
+ tr.insertCell(-1).innerHTML = st[i].intport;
+
+ tr.insertCell(-1).innerHTML = String.format(
+ '<input class="cbi-button cbi-input-remove" type="button" value="<%:Delete Redirect%>" onclick="upnp_delete_fwd(%d)" />',
+ st[i].num
+ );
+ }
+
+ if( tb.rows.length == 1 )
+ {
+ var tr = tb.insertRow(-1);
+ tr.className = 'cbi-section-table-row';
+
+ var td = tr.insertCell(-1);
+ td.colSpan = 5;
+ td.innerHTML = '<em><br /><%:There are no active redirects.%></em>';
+ }
+ }
+ }
+ );
+//]]></script>
+
+<fieldset class="cbi-section">
+ <legend><%:Active UPnP Redirects%></legend>
+ <table class="cbi-section-table" id="upnp_status_table">
+ <tr class="cbi-section-table-titles">
+ <th class="cbi-section-table-cell"><%:Protocol%></th>
+ <th class="cbi-section-table-cell"><%:External Port%></th>
+ <th class="cbi-section-table-cell"><%:Client Address%></th>
+ <th class="cbi-section-table-cell"><%:Client Port%></th>
+ <th class="cbi-section-table-cell">&#160;</th>
+ </tr>
+ <tr class="cbi-section-table-row">
+ <td colspan="5"><em><br /><%:Collecting data...%></em></td>
+ </tr>
+ </table>
+</fieldset>