summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-uhttpd/Makefile
diff options
context:
space:
mode:
authorDaniel Dickinson <openwrt@daniel.thecshore.com>2015-12-02 00:25:30 -0500
committerDaniel Dickinson <openwrt@daniel.thecshore.com>2015-12-15 13:09:46 -0500
commitd83642c20519692c5d3883e23d01bb84a48dd85a (patch)
tree4eddfd64c6892ce81263cd1bf425f6469e28b88b /applications/luci-app-uhttpd/Makefile
parent6509e007e29f438d74b01eb6e23a09f02775dd6c (diff)
applications: uhttpd: Add a uHTTPd configuration app
uHTTPd has a lot of useful options that ought to be configurable without have to SSH in, so expose those options in a UI page.
Diffstat (limited to 'applications/luci-app-uhttpd/Makefile')
-rw-r--r--applications/luci-app-uhttpd/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/applications/luci-app-uhttpd/Makefile b/applications/luci-app-uhttpd/Makefile
new file mode 100644
index 0000000000..9a2cf462e5
--- /dev/null
+++ b/applications/luci-app-uhttpd/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=uHTTPd Webserver Configuration
+LUCI_DEPENDS:=+uhttpd
+LUCI_PKGARCH:=all
+
+PKG_NAME:=luci-app-uhttpd
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Daniel Dickinson <openwrt@daniel.thecshore.com>
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+LUA_TARGET:=source
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature