summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-uhttpd/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-01-15 15:20:41 +0100
committerJo-Philipp Wich <jow@openwrt.org>2016-01-15 15:20:41 +0100
commitad064f0b039839dd333bfe8e9631cbc5218410b0 (patch)
treec13911127dbab695710aa784b54b22e794f1a43c /applications/luci-app-uhttpd/Makefile
parent1a7b0b22a85d8294d7a2c196b708266c872dd054 (diff)
parentb130ca554f13e17c787a1c6fd09e67dd7727a4d3 (diff)
Merge pull request #563 from cshore/pull-request-app-uhttpd
Pull request app uhttpd
Diffstat (limited to 'applications/luci-app-uhttpd/Makefile')
-rw-r--r--applications/luci-app-uhttpd/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/applications/luci-app-uhttpd/Makefile b/applications/luci-app-uhttpd/Makefile
new file mode 100644
index 0000000000..9a2cf462e5
--- /dev/null
+++ b/applications/luci-app-uhttpd/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=uHTTPd Webserver Configuration
+LUCI_DEPENDS:=+uhttpd
+LUCI_PKGARCH:=all
+
+PKG_NAME:=luci-app-uhttpd
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Daniel Dickinson <openwrt@daniel.thecshore.com>
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+LUA_TARGET:=source
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature