summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-udpxy
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-udpxy
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-udpxy')
-rw-r--r--applications/luci-app-udpxy/Makefile14
-rw-r--r--applications/luci-app-udpxy/luasrc/controller/udpxy.lua25
-rw-r--r--applications/luci-app-udpxy/luasrc/model/cbi/udpxy.lua74
-rw-r--r--applications/luci-app-udpxy/root/etc/uci-defaults/luci-udpxy12
4 files changed, 125 insertions, 0 deletions
diff --git a/applications/luci-app-udpxy/Makefile b/applications/luci-app-udpxy/Makefile
new file mode 100644
index 000000000..cb8f17923
--- /dev/null
+++ b/applications/luci-app-udpxy/Makefile
@@ -0,0 +1,14 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=LuCI Support for udpxy
+LUCI_DEPENDS:=+udpxy
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-udpxy/luasrc/controller/udpxy.lua b/applications/luci-app-udpxy/luasrc/controller/udpxy.lua
new file mode 100644
index 000000000..bc85b0bb0
--- /dev/null
+++ b/applications/luci-app-udpxy/luasrc/controller/udpxy.lua
@@ -0,0 +1,25 @@
+--[[
+LuCI - Lua Configuration Interface - udpxy support
+
+Copyright 2014 Álvaro Fernández Rojas <noltari@gmail.com>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+
+module("luci.controller.udpxy", package.seeall)
+
+function index()
+ if not nixio.fs.access("/etc/config/udpxy") then
+ return
+ end
+
+ local page = entry({"admin", "services", "udpxy"}, cbi("udpxy"), _("udpxy"))
+ page.dependent = true
+
+end
diff --git a/applications/luci-app-udpxy/luasrc/model/cbi/udpxy.lua b/applications/luci-app-udpxy/luasrc/model/cbi/udpxy.lua
new file mode 100644
index 000000000..b08f93baf
--- /dev/null
+++ b/applications/luci-app-udpxy/luasrc/model/cbi/udpxy.lua
@@ -0,0 +1,74 @@
+--[[
+LuCI - Lua Configuration Interface - udpxy support
+
+Copyright 2014 Álvaro Fernández Rojas <noltari@gmail.com>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+
+m = Map("udpxy", "udpxy", translate("udpxy is a UDP-to-HTTP multicast traffic relay daemon, here you can configure the settings."))
+
+s = m:section(TypedSection, "udpxy", "")
+s.addremove = true
+s.anonymous = false
+
+enable=s:option(Flag, "disabled", translate("Enabled"))
+enable.enabled="0"
+enable.disabled="1"
+enable.default = "1"
+enable.rmempty = false
+respawn=s:option(Flag, "respawn", translate("Respawn"))
+respawn.default = false
+
+verbose=s:option(Flag, "verbose", translate("Verbose"))
+verbose.default = false
+
+status=s:option(Flag, "status", translate("Status"))
+
+bind=s:option(Value, "bind", translate("Bind IP/Interface"))
+bind.rmempty = true
+bind.datatype = "or(ipaddr, network)"
+
+port=s:option(Value, "port", translate("Port"))
+port.rmempty = true
+port.datatype = "port"
+
+source=s:option(Value, "source", translate("Source IP/Interface"))
+source.rmempty = true
+source.datatype = "or(ipaddr, network)"
+
+max_clients=s:option(Value, "max_clients", translate("Max clients"))
+max_clients.rmempty = true
+max_clients.datatype = "range(1, 5000)"
+
+log_file=s:option(Value, "log_file", translate("Log file"))
+log_file.rmempty = true
+--log_file.datatype = "file"
+
+buffer_size=s:option(Value, "buffer_size", translate("Buffer size"))
+buffer_size.rmempty = true
+buffer_size.datatype = "range(4096,2097152)"
+
+buffer_messages=s:option(Value, "buffer_messages", translate("Buffer messages"))
+buffer_messages.rmempty = true
+buffer_messages.datatype = "or(-1, and(min(1), uinteger))"
+
+buffer_time=s:option(Value, "buffer_time", translate("Buffer time"))
+buffer_time.rmempty = true
+buffer_time.datatype = "or(-1, and(min(1), uinteger))"
+
+nice_increment=s:option(Value, "nice_increment", translate("Nice increment"))
+nice_increment.rmempty = true
+nice_increment.datatype = "or(and(max(-1), integer),and(min(1), integer))"
+
+mcsub_renew=s:option(Value, "mcsub_renew", translate("Multicast subscription renew"))
+mcsub_renew.rmempty = true
+mcsub_renew.datatype = "or(0, range(30, 64000))"
+
+return m
diff --git a/applications/luci-app-udpxy/root/etc/uci-defaults/luci-udpxy b/applications/luci-app-udpxy/root/etc/uci-defaults/luci-udpxy
new file mode 100644
index 000000000..e93c07880
--- /dev/null
+++ b/applications/luci-app-udpxy/root/etc/uci-defaults/luci-udpxy
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+# needed for "Save and Apply" to restart udpxy
+uci -q batch <<-EOF >/dev/null
+ delete ucitrack.@udpxy[-1]
+ add ucitrack udpxy
+ set ucitrack.@udpxy[-1].init="udpxy"
+ commit ucitrack
+EOF
+
+rm -f /tmp/luci-indexcache
+exit 0