summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-tinyproxy/luasrc/view/tinyproxy_status.htm
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-tinyproxy/luasrc/view/tinyproxy_status.htm
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-tinyproxy/luasrc/view/tinyproxy_status.htm')
-rw-r--r--applications/luci-app-tinyproxy/luasrc/view/tinyproxy_status.htm50
1 files changed, 50 insertions, 0 deletions
diff --git a/applications/luci-app-tinyproxy/luasrc/view/tinyproxy_status.htm b/applications/luci-app-tinyproxy/luasrc/view/tinyproxy_status.htm
new file mode 100644
index 0000000000..c85a206bd3
--- /dev/null
+++ b/applications/luci-app-tinyproxy/luasrc/view/tinyproxy_status.htm
@@ -0,0 +1,50 @@
+<%
+
+if luci.http.formvalue("frame") == "1" then
+ local uci = require "luci.model.uci".cursor()
+ local addr = "127.0.0.1"
+ local port = "8888"
+
+ uci:foreach("tinyproxy", "tinyproxy",
+ function(s)
+ addr = s.StatHost or addr
+ port = s.Port or port
+ return false
+ end)
+
+ local data = false
+ local wget = io.popen("wget -qO- http://%s:%s" % { addr, port })
+ if wget then
+ while true do
+ local l = wget:read("*l")
+ if not l then
+ break
+ end
+
+ luci.http.write(l)
+ data = true
+ end
+
+ wget:close()
+ end
+
+ if not data then
+ luci.http.write(translate("Failed to retrieve statistics from url:"))
+ luci.http.write(" http://%s:%s" % { addr, port })
+ end
+
+ return
+end
+
+-%>
+
+<%+header%>
+
+<div class="cbi-map">
+ <h2><a id="content" name="content"><%:Tinyproxy Status%></a></h2>
+ <div class="cbi-section">
+ <iframe src="<%=REQUESTURL%>?frame=1" style="width:100%; height:350px; border:none"></iframe>
+ </div>
+</div>
+
+<%+footer%>