summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/df.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/df.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/df.lua')
-rw-r--r--applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/df.lua53
1 files changed, 53 insertions, 0 deletions
diff --git a/applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/df.lua b/applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/df.lua
new file mode 100644
index 000000000..1a3245fc0
--- /dev/null
+++ b/applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/df.lua
@@ -0,0 +1,53 @@
+--[[
+
+Luci configuration model for statistics - collectd df plugin configuration
+(c) 2008 Freifunk Leipzig / Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+m = Map("luci_statistics",
+ translate("DF Plugin Configuration"),
+ translate(
+ "The df plugin collects statistics about the disk space " ..
+ "usage on different devices, mount points or filesystem types."
+ ))
+
+-- collectd_df config section
+s = m:section( NamedSection, "collectd_df", "luci_statistics" )
+
+-- collectd_df.enable
+enable = s:option( Flag, "enable", translate("Enable this plugin") )
+enable.default = 0
+
+-- collectd_df.devices (Device)
+devices = s:option( Value, "Devices", translate("Monitor devices") )
+devices.default = "/dev/mtdblock/4"
+devices.optional = true
+devices:depends( "enable", 1 )
+
+-- collectd_df.mountpoints (MountPoint)
+mountpoints = s:option( Value, "MountPoints", translate("Monitor mount points") )
+mountpoints.default = "/overlay"
+mountpoints.optional = true
+mountpoints:depends( "enable", 1 )
+
+-- collectd_df.fstypes (FSType)
+fstypes = s:option( Value, "FSTypes", translate("Monitor filesystem types") )
+fstypes.default = "tmpfs"
+fstypes.optional = true
+fstypes:depends( "enable", 1 )
+
+-- collectd_df.ignoreselected (IgnoreSelected)
+ignoreselected = s:option( Flag, "IgnoreSelected", translate("Monitor all except specified") )
+ignoreselected.default = 0
+ignoreselected:depends( "enable", 1 )
+
+return m