summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-statistics/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-statistics/Makefile
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-statistics/Makefile')
-rw-r--r--applications/luci-app-statistics/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/applications/luci-app-statistics/Makefile b/applications/luci-app-statistics/Makefile
new file mode 100644
index 000000000..af07cfbd0
--- /dev/null
+++ b/applications/luci-app-statistics/Makefile
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=LuCI Statistics Application
+LUCI_DEPENDS:= \
+ +collectd +rrdtool1 +collectd-mod-rrdtool +collectd-mod-iwinfo \
+ +collectd-mod-interface +collectd-mod-load +collectd-mod-network
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature