summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-splash/root/etc/hotplug.d/iface
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-splash/root/etc/hotplug.d/iface
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-splash/root/etc/hotplug.d/iface')
-rw-r--r--applications/luci-app-splash/root/etc/hotplug.d/iface/25-splash17
1 files changed, 17 insertions, 0 deletions
diff --git a/applications/luci-app-splash/root/etc/hotplug.d/iface/25-splash b/applications/luci-app-splash/root/etc/hotplug.d/iface/25-splash
new file mode 100644
index 0000000000..045e908c72
--- /dev/null
+++ b/applications/luci-app-splash/root/etc/hotplug.d/iface/25-splash
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+[ "$ACTION" = ifup ] || exit 0
+
+/etc/init.d/firewall enabled || exit 0
+
+if [ -x /etc/init.d/luci_splash ]; then
+ restart_splash() {
+ local net="$1"
+ if [ "$INTERFACE" = "$net" ]; then
+ logger -t splash "Reloading splash firewall rules due to ifup of $INTERFACE ($DEVICE)"
+ /etc/init.d/luci_splash restart
+ fi
+ }
+ config_load luci_splash
+ config_foreach restart_splash iface
+fi