summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-smartdns/Makefile
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2020-07-02 18:39:21 +0200
committerGitHub <noreply@github.com>2020-07-02 18:39:21 +0200
commit9f95d43b6708b5760a6854c18c043e58f1c3ff83 (patch)
tree0c4052cc4cfdab38da0c280680890675918fe0cc /applications/luci-app-smartdns/Makefile
parent2e2ab59eafc3673b1710260d3754e79f46ccd309 (diff)
parent7aad18cbac961f6ec75580c107e91d476fd4284a (diff)
Merge pull request #3413 from pymumu/master
luci-app-smartdns: add new package
Diffstat (limited to 'applications/luci-app-smartdns/Makefile')
-rw-r--r--applications/luci-app-smartdns/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/applications/luci-app-smartdns/Makefile b/applications/luci-app-smartdns/Makefile
new file mode 100644
index 0000000000..878fbf7394
--- /dev/null
+++ b/applications/luci-app-smartdns/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright 2018-2020 Nick Peng <pymumu@gmail.com>
+# Licensed to the public under the GPL V3 License.
+
+include $(TOPDIR)/rules.mk
+
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_MAINTAINER:=Nick Peng <pymumu@gmail.com>
+PKG_VERSION:=1.2020.30
+PKG_RELEASE:=1
+
+LUCI_TITLE:=LuCI for smartdns
+LUCI_DESCRIPTION:=Provides Luci for smartdns
+LUCI_DEPENDS:=+smartdns
+LUCI_PKGARCH:=all
+
+define Package/$(PKG_NAME)/config
+# shown in make menuconfig <Help>
+help
+ $(LUCI_TITLE)
+ Version: $(PKG_VERSION)-$(PKG_RELEASE)
+endef
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature