summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-siitwizard/luasrc/controller/siitwizard.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-siitwizard/luasrc/controller/siitwizard.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-siitwizard/luasrc/controller/siitwizard.lua')
-rw-r--r--applications/luci-app-siitwizard/luasrc/controller/siitwizard.lua21
1 files changed, 21 insertions, 0 deletions
diff --git a/applications/luci-app-siitwizard/luasrc/controller/siitwizard.lua b/applications/luci-app-siitwizard/luasrc/controller/siitwizard.lua
new file mode 100644
index 0000000000..2e0fd0812a
--- /dev/null
+++ b/applications/luci-app-siitwizard/luasrc/controller/siitwizard.lua
@@ -0,0 +1,21 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+module "luci.controller.siitwizard"
+
+function index()
+ entry({"admin", "network", "siitwizard"}, form("siitwizard"), "SIIT 4over6 assistent", 99)
+end