summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-radvd/luasrc/controller
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-radvd/luasrc/controller
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-radvd/luasrc/controller')
-rw-r--r--applications/luci-app-radvd/luasrc/controller/radvd.lua28
1 files changed, 28 insertions, 0 deletions
diff --git a/applications/luci-app-radvd/luasrc/controller/radvd.lua b/applications/luci-app-radvd/luasrc/controller/radvd.lua
new file mode 100644
index 0000000000..58dcbb2eac
--- /dev/null
+++ b/applications/luci-app-radvd/luasrc/controller/radvd.lua
@@ -0,0 +1,28 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2010 Jo-Philipp Wich <xm@subsignal.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+
+module("luci.controller.radvd", package.seeall)
+
+function index()
+ if not nixio.fs.access("/etc/config/radvd") then
+ return
+ end
+
+ entry({"admin", "network", "radvd"}, cbi("radvd"), _("Radvd"), 61)
+ entry({"admin", "network", "radvd", "interface"}, cbi("radvd/interface"), nil).leaf = true
+ entry({"admin", "network", "radvd", "prefix"}, cbi("radvd/prefix"), nil).leaf = true
+ entry({"admin", "network", "radvd", "route"}, cbi("radvd/route"), nil).leaf = true
+ entry({"admin", "network", "radvd", "rdnss"}, cbi("radvd/rdnss"), nil).leaf = true
+ entry({"admin", "network", "radvd", "dnssl"}, cbi("radvd/dnssl"), nil).leaf = true
+end