summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-privoxy/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-25 12:36:50 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-25 12:36:50 +0100
commitc69bbad727370edbf69348024cfa7ffb7b48a6f1 (patch)
tree8844c069ab2715dcfaa9fd4b579651c7c10410e8 /applications/luci-app-privoxy/Makefile
parent9feb1b8a7828cd025cb3bf8a0e58085cf1da64ca (diff)
parent29f7cf16e56c269f45184677dfaa472499622fdb (diff)
Merge pull request #308 from chris5560/master
luci-app-privoxy: move from openwrt/packages to openwrt/luci
Diffstat (limited to 'applications/luci-app-privoxy/Makefile')
-rw-r--r--applications/luci-app-privoxy/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/applications/luci-app-privoxy/Makefile b/applications/luci-app-privoxy/Makefile
new file mode 100644
index 000000000..67284ef30
--- /dev/null
+++ b/applications/luci-app-privoxy/Makefile
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2008-2015 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+# LuCI specific settings
+LUCI_TITLE:=LuCI Support for Privoxy WEB proxy
+LUCI_DEPENDS:=+luci-mod-admin-full +privoxy
+LUCI_PKGARCH:=all
+
+PKG_NAME:=luci-app-privoxy
+
+# Version == major.minor.patch
+# increase "minor" on new functionality and "patch" on patches/optimization
+PKG_VERSION:=1.0.2
+
+# Release == build
+# increase on changes of translation files
+PKG_RELEASE:=0
+
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
+
+define Package/$(PKG_NAME)/config
+# shown in make menuconfig <Help>
+help
+ $(LUCI_TITLE)
+
+ Version : $(PKG_VERSION)-$(PKG_RELEASE)
+ Maintainer: $(PKG_MAINTAINER)
+endef
+
+include ./luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature