summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-polipo/root
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-polipo/root
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-polipo/root')
-rwxr-xr-xapplications/luci-app-polipo/root/etc/uci-defaults/luci-polipo11
-rwxr-xr-xapplications/luci-app-polipo/root/usr/sbin/polipo_purge18
2 files changed, 29 insertions, 0 deletions
diff --git a/applications/luci-app-polipo/root/etc/uci-defaults/luci-polipo b/applications/luci-app-polipo/root/etc/uci-defaults/luci-polipo
new file mode 100755
index 000000000..0c570630d
--- /dev/null
+++ b/applications/luci-app-polipo/root/etc/uci-defaults/luci-polipo
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+uci -q batch <<-EOF >/dev/null
+ delete ucitrack.@polipo[-1]
+ add ucitrack polipo
+ set ucitrack.@polipo[-1].init=polipo
+ commit ucitrack
+EOF
+
+rm -f /tmp/luci-indexcache
+exit 0
diff --git a/applications/luci-app-polipo/root/usr/sbin/polipo_purge b/applications/luci-app-polipo/root/usr/sbin/polipo_purge
new file mode 100755
index 000000000..23ba57192
--- /dev/null
+++ b/applications/luci-app-polipo/root/usr/sbin/polipo_purge
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+DAEMON=/usr/sbin/polipo
+PIDFILE=`uci get polipo.daemon.pidFile`
+CFGFILE=/var/etc/polipo.conf
+
+[ -e "$PIDFILE" ] && {
+ PID=`cat $PIDFILE`
+
+ # send Polipo USR1 signal to write its in-memory cache to disk
+ kill -USR1 $PID
+ sleep 2
+ # start polipo with -x flag to purge the on-disk cache
+ polipo -c $CFGFILE -x
+ # send Polipo USR2 signal to discard its in-memory cache
+ kill -USR2 $PID
+}
+