summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-pbx/luasrc/controller
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-pbx/luasrc/controller
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-pbx/luasrc/controller')
-rw-r--r--applications/luci-app-pbx/luasrc/controller/pbx.lua29
1 files changed, 29 insertions, 0 deletions
diff --git a/applications/luci-app-pbx/luasrc/controller/pbx.lua b/applications/luci-app-pbx/luasrc/controller/pbx.lua
new file mode 100644
index 0000000000..b77814b150
--- /dev/null
+++ b/applications/luci-app-pbx/luasrc/controller/pbx.lua
@@ -0,0 +1,29 @@
+--[[
+ Copyright 2011 Iordan Iordanov <iiordanov (AT) gmail.com>
+
+ This file is part of luci-pbx.
+
+ luci-pbx is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation, either version 3 of the License, or
+ (at your option) any later version.
+
+ luci-pbx is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with luci-pbx. If not, see <http://www.gnu.org/licenses/>.
+]]--
+
+module("luci.controller.pbx", package.seeall)
+
+function index()
+ entry({"admin", "services", "pbx"}, cbi("pbx"), "PBX", 80)
+ entry({"admin", "services", "pbx", "pbx-google"}, cbi("pbx-google"), "Google Accounts", 1)
+ entry({"admin", "services", "pbx", "pbx-voip"}, cbi("pbx-voip"), "SIP Accounts", 2)
+ entry({"admin", "services", "pbx", "pbx-users"}, cbi("pbx-users"), "User Accounts", 3)
+ entry({"admin", "services", "pbx", "pbx-calls"}, cbi("pbx-calls"), "Call Routing", 4)
+ entry({"admin", "services", "pbx", "pbx-advanced"}, cbi("pbx-advanced"), "Advanced Settings", 6)
+end