summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-p2pblock/luasrc/controller/ff_p2pblock.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-p2pblock/luasrc/controller/ff_p2pblock.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-p2pblock/luasrc/controller/ff_p2pblock.lua')
-rw-r--r--applications/luci-app-p2pblock/luasrc/controller/ff_p2pblock.lua20
1 files changed, 20 insertions, 0 deletions
diff --git a/applications/luci-app-p2pblock/luasrc/controller/ff_p2pblock.lua b/applications/luci-app-p2pblock/luasrc/controller/ff_p2pblock.lua
new file mode 100644
index 000000000..887f18756
--- /dev/null
+++ b/applications/luci-app-p2pblock/luasrc/controller/ff_p2pblock.lua
@@ -0,0 +1,20 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2009 Jo-Philipp Wich <xm@subsignal.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+
+module("luci.controller.ff_p2pblock", package.seeall)
+
+function index()
+ entry({"admin", "network", "firewall", "p2pblock"}, cbi("luci_fw/p2pblock"),
+ _("P2P-Block"), 40)
+end