summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-openvpn/luasrc/view/openvpn
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-openvpn/luasrc/view/openvpn
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-openvpn/luasrc/view/openvpn')
-rw-r--r--applications/luci-app-openvpn/luasrc/view/openvpn/cbi-select-input-add.htm11
-rw-r--r--applications/luci-app-openvpn/luasrc/view/openvpn/pageswitch.htm45
2 files changed, 56 insertions, 0 deletions
diff --git a/applications/luci-app-openvpn/luasrc/view/openvpn/cbi-select-input-add.htm b/applications/luci-app-openvpn/luasrc/view/openvpn/cbi-select-input-add.htm
new file mode 100644
index 000000000..0166de778
--- /dev/null
+++ b/applications/luci-app-openvpn/luasrc/view/openvpn/cbi-select-input-add.htm
@@ -0,0 +1,11 @@
+<div class="cbi-section-create">
+ <% if self.invalid_cts then -%><div class="cbi-section-error"><% end %>
+ <input type="text" class="cbi-section-create-name" name="cbi.cts.<%=self.config%>.<%=self.sectiontype%>.text" />
+ <select class="cbi-section-create-name" name="cbi.cts.<%=self.config%>.<%=self.sectiontype%>.select">
+ <%- for k, v in luci.util.kspairs(self.add_select_options) do %>
+ <option value="<%=k%>"><%=luci.util.pcdata(v)%></option>
+ <% end -%>
+ </select>
+ <input class="cbi-button cbi-button-add" type="submit" value="<%:Add%>" title="<%:Add%>" />
+ <% if self.invalid_cts then %><br /><%:Invalid%></div><% end %>
+</div>
diff --git a/applications/luci-app-openvpn/luasrc/view/openvpn/pageswitch.htm b/applications/luci-app-openvpn/luasrc/view/openvpn/pageswitch.htm
new file mode 100644
index 000000000..4f4e869e5
--- /dev/null
+++ b/applications/luci-app-openvpn/luasrc/view/openvpn/pageswitch.htm
@@ -0,0 +1,45 @@
+<%#
+LuCI - Lua Configuration Interface
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+These strings need to be here to be included in the translation template
+translate("Service")
+translate("Networking")
+translate("VPN")
+translate("Cryptography")
+
+-%>
+
+<fieldset class="cbi-section">
+ <legend>
+ <a href="<%=luci.dispatcher.build_url("admin", "services", "openvpn")%>"><%:Overview%></a> &raquo;
+ <%=luci.i18n.translatef("Instance \"%s\"", self.instance)%>
+ </legend>
+
+ <% if self.mode == "basic" then %>
+ <a href="<%=luci.dispatcher.build_url("admin", "services", "openvpn", "advanced", self.instance, "Service")%>"><%:Switch to advanced configuration »%></a>
+ <% else %>
+ <a href="<%=luci.dispatcher.build_url("admin", "services", "openvpn", "basic", self.instance)%>"><%:« Switch to basic configuration%></a>
+ <hr style="margin:0.5em 0" />
+ <%:Configuration category%>:
+ <% for i, c in ipairs(self.categories) do %>
+ <% if c == self.category then %>
+ <strong><%=translate(c)%></strong>
+ <% else %>
+ <a href="<%=luci.dispatcher.build_url(
+ "admin", "services", "openvpn", "advanced", self.instance, c
+ )%>"><%=translate(c)%></a>
+ <% end %>
+ <% if next(self.categories, i) then %>|<% end %>
+ <% end %>
+ <% end %>
+</fieldset>