summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-olsr-services/luasrc/controller/services.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-olsr-services/luasrc/controller/services.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-olsr-services/luasrc/controller/services.lua')
-rw-r--r--applications/luci-app-olsr-services/luasrc/controller/services.lua16
1 files changed, 16 insertions, 0 deletions
diff --git a/applications/luci-app-olsr-services/luasrc/controller/services.lua b/applications/luci-app-olsr-services/luasrc/controller/services.lua
new file mode 100644
index 0000000000..a4636bfd57
--- /dev/null
+++ b/applications/luci-app-olsr-services/luasrc/controller/services.lua
@@ -0,0 +1,16 @@
+module "luci.controller.services"
+
+function index()
+ local uci = require "luci.model.uci".cursor()
+
+ uci:foreach("olsrd", "LoadPlugin", function(s)
+ if s.library == "olsrd_nameservice.so.0.3" then
+ has_serv = true
+ end
+ end)
+
+ if has_serv then
+ entry({"freifunk", "services"}, template("freifunk-services/services"), _("Services"), 60)
+ end
+end
+