summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-ntpc/luasrc/model
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-ntpc/luasrc/model
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-ntpc/luasrc/model')
-rw-r--r--applications/luci-app-ntpc/luasrc/model/cbi/ntpc/ntpc.lua49
-rw-r--r--applications/luci-app-ntpc/luasrc/model/cbi/ntpc/ntpcmini.lua38
2 files changed, 87 insertions, 0 deletions
diff --git a/applications/luci-app-ntpc/luasrc/model/cbi/ntpc/ntpc.lua b/applications/luci-app-ntpc/luasrc/model/cbi/ntpc/ntpc.lua
new file mode 100644
index 000000000..5265359c6
--- /dev/null
+++ b/applications/luci-app-ntpc/luasrc/model/cbi/ntpc/ntpc.lua
@@ -0,0 +1,49 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+m = Map("ntpclient", translate("Time Synchronisation"), translate("Synchronizes the system time"))
+
+s = m:section(TypedSection, "ntpclient", translate("General"))
+s.anonymous = true
+s.addremove = false
+
+s:option(DummyValue, "_time", translate("Current system time")).value = os.date("%c")
+
+interval = s:option(Value, "interval", translate("Update interval (in seconds)"))
+interval.datatype = "and(uinteger,min(1))"
+interval.rmempty = true
+
+count = s:option(Value, "count", translate("Count of time measurements"), translate("empty = infinite"))
+count.datatype = "and(uinteger,min(1))"
+count.rmempty = true
+
+s2 = m:section(TypedSection, "ntpdrift", translate("Clock Adjustment"))
+s2.anonymous = true
+s2.addremove = false
+
+freq = s2:option(Value, "freq", translate("Offset frequency"))
+freq.datatype = "integer"
+freq.rmempty = true
+
+s3 = m:section(TypedSection, "ntpserver", translate("Time Servers"))
+s3.anonymous = true
+s3.addremove = true
+s3.template = "cbi/tblsection"
+
+s3:option(Value, "hostname", translate("Hostname"))
+port = s3:option(Value, "port", translate("Port"))
+port.datatype = "port"
+port.rmempty = true
+
+return m
diff --git a/applications/luci-app-ntpc/luasrc/model/cbi/ntpc/ntpcmini.lua b/applications/luci-app-ntpc/luasrc/model/cbi/ntpc/ntpcmini.lua
new file mode 100644
index 000000000..2a6c41524
--- /dev/null
+++ b/applications/luci-app-ntpc/luasrc/model/cbi/ntpc/ntpcmini.lua
@@ -0,0 +1,38 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+require("luci.tools.webadmin")
+m = Map("ntpclient", translate("Time Synchronisation"), translate("Synchronizes the system time"))
+
+s = m:section(TypedSection, "ntpclient", translate("General"))
+s.anonymous = true
+s.addremove = false
+
+s:option(DummyValue, "_time", translate("Current system time")).value = os.date("%c")
+
+interval = s:option(Value, "interval", translate("Update interval (in seconds)"))
+interval.datatype = "and(uinteger,min(1))"
+interval.rmempty = true
+
+s3 = m:section(TypedSection, "ntpserver", translate("Time Server"))
+s3.anonymous = true
+s3.addremove = true
+s3.template = "cbi/tblsection"
+
+s3:option(Value, "hostname", translate("Hostname"))
+port = s3:option(Value, "port", translate("Port"))
+port.datatype = "port"
+port.rmempty = true
+
+return m