summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-mosquitto/luasrc/controller/mosquitto.lua
diff options
context:
space:
mode:
authorKarl Palsson <karlp@etactica.com>2018-09-18 12:47:40 +0000
committerKarl Palsson <karlp@etactica.com>2018-09-18 15:44:52 +0000
commit7552fce8cc220e378c6b28384cc759aba437ce13 (patch)
tree021d9fe2cded49895cd1bbaa09dfb6b284024d07 /applications/luci-app-mosquitto/luasrc/controller/mosquitto.lua
parent00c95d7906fa7409510dcd50fc3f38521d521ed4 (diff)
luci-app-mosquitto: import new application
Originally developed and maintained at https://github.com/remakeelectric/owrt_pub_feeds/tree/master/luci-app-mosquitto Vs the original, this version has been converted to use the luci.mk style, and has dropped the now obsolete ucitrack entries. Signed-off-by: Karl Palsson <karlp@etactica.com>
Diffstat (limited to 'applications/luci-app-mosquitto/luasrc/controller/mosquitto.lua')
-rw-r--r--applications/luci-app-mosquitto/luasrc/controller/mosquitto.lua16
1 files changed, 16 insertions, 0 deletions
diff --git a/applications/luci-app-mosquitto/luasrc/controller/mosquitto.lua b/applications/luci-app-mosquitto/luasrc/controller/mosquitto.lua
new file mode 100644
index 000000000..587054eb1
--- /dev/null
+++ b/applications/luci-app-mosquitto/luasrc/controller/mosquitto.lua
@@ -0,0 +1,16 @@
+--[[
+LuCI - Lua Configuration Interface for mosquitto
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+
+module("luci.controller.mosquitto", package.seeall)
+
+function index()
+ entry({"admin", "services", "mosquitto"}, cbi("mosquitto"), _("Mosquitto"))
+end