summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-meshwizard/luasrc/controller
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-meshwizard/luasrc/controller
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-meshwizard/luasrc/controller')
-rw-r--r--applications/luci-app-meshwizard/luasrc/controller/meshwizard.lua19
1 files changed, 19 insertions, 0 deletions
diff --git a/applications/luci-app-meshwizard/luasrc/controller/meshwizard.lua b/applications/luci-app-meshwizard/luasrc/controller/meshwizard.lua
new file mode 100644
index 000000000..942987db5
--- /dev/null
+++ b/applications/luci-app-meshwizard/luasrc/controller/meshwizard.lua
@@ -0,0 +1,19 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2011 Manuel Munz <freifunk somakoma de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+
+module "luci.controller.meshwizard"
+
+function index()
+ entry({"admin", "freifunk", "meshwizard"}, cbi("freifunk/meshwizard"), _("Mesh Wizard"), 40)
+end
+