summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-ltqtapi/luasrc/controller
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-ltqtapi/luasrc/controller
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-ltqtapi/luasrc/controller')
-rw-r--r--applications/luci-app-ltqtapi/luasrc/controller/ltqtapi.lua50
1 files changed, 50 insertions, 0 deletions
diff --git a/applications/luci-app-ltqtapi/luasrc/controller/ltqtapi.lua b/applications/luci-app-ltqtapi/luasrc/controller/ltqtapi.lua
new file mode 100644
index 0000000000..abce09cea8
--- /dev/null
+++ b/applications/luci-app-ltqtapi/luasrc/controller/ltqtapi.lua
@@ -0,0 +1,50 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2019 John Crispin <blogic@openwrt.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+
+module("luci.controller.ltqtapi", package.seeall)
+
+function index()
+ if not nixio.fs.access("/etc/config/telephony") then
+ return
+ end
+
+ page = node("admin", "telephony")
+ page.target = firstchild()
+ page.title = _("VoIP")
+ page.order = 90
+
+ entry({"admin", "telephony", "account"}, cbi("luci_ltqtapi/account") , _("Account"), 10)
+ entry({"admin", "telephony", "contact"}, cbi("luci_ltqtapi/contact") , _("Contacts"), 20)
+
+ entry({"admin", "telephony", "status"}, call("tapi_status")).leaf = true
+end
+
+function tapi_status()
+ local st = { }
+ local state = require "luci.model.uci".cursor_state()
+ state:load("telephony")
+
+ st.status = "Offline";
+ if state:get("telephony", "state", "port1", "0") == "0" then
+ st.line1 = "Idle";
+ else
+ st.line1 = "Calling";
+ end
+ if state:get("telephony", "state", "port2", "0") == "0" then
+ st.line2 = "Idle";
+ else
+ st.line2 = "Calling";
+ end
+ luci.http.prepare_content("application/json")
+ luci.http.write_json(st)
+end