summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-hd-idle/luasrc/model
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-hd-idle/luasrc/model
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-hd-idle/luasrc/model')
-rw-r--r--applications/luci-app-hd-idle/luasrc/model/cbi/hd_idle.lua41
1 files changed, 41 insertions, 0 deletions
diff --git a/applications/luci-app-hd-idle/luasrc/model/cbi/hd_idle.lua b/applications/luci-app-hd-idle/luasrc/model/cbi/hd_idle.lua
new file mode 100644
index 000000000..0c844ca4e
--- /dev/null
+++ b/applications/luci-app-hd-idle/luasrc/model/cbi/hd_idle.lua
@@ -0,0 +1,41 @@
+--[[
+
+LuCI hd-idle
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+require("nixio.fs")
+
+m = Map("hd-idle", "hd-idle",
+ translate("hd-idle is a utility program for spinning-down external " ..
+ "disks after a period of idle time."))
+
+s = m:section(TypedSection, "hd-idle", translate("Settings"))
+s.anonymous = true
+
+s:option(Flag, "enabled", translate("Enable"))
+
+disk = s:option(Value, "disk", translate("Disk"))
+disk.rmempty = true
+for dev in nixio.fs.glob("/dev/[sh]d[a-z]") do
+ disk:value(nixio.fs.basename(dev))
+end
+
+s:option(Value, "idle_time_interval", translate("Idle-time")).default = 10
+s.rmempty = true
+unit = s:option(ListValue, "idle_time_unit", translate("Idle-time unit"))
+unit.default = "minutes"
+unit:value("minutes", translate("min"))
+unit:value("hours", translate("h"))
+unit.rmempty = true
+
+return m