summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-freifunk-widgets/luasrc/controller
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-freifunk-widgets/luasrc/controller
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-freifunk-widgets/luasrc/controller')
-rw-r--r--applications/luci-app-freifunk-widgets/luasrc/controller/freifunk/widgets.lua44
1 files changed, 44 insertions, 0 deletions
diff --git a/applications/luci-app-freifunk-widgets/luasrc/controller/freifunk/widgets.lua b/applications/luci-app-freifunk-widgets/luasrc/controller/freifunk/widgets.lua
new file mode 100644
index 000000000..5bbd53f57
--- /dev/null
+++ b/applications/luci-app-freifunk-widgets/luasrc/controller/freifunk/widgets.lua
@@ -0,0 +1,44 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2012 Manuel Munz <freifunk at somakoma de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+local require = require
+module "luci.controller.freifunk.widgets"
+
+
+function index()
+
+ local page = node("admin", "freifunk", "widgets")
+ page.target = cbi("freifunk/widgets/widgets_overview")
+ page.title = _("Widgets")
+ page.i18n = "widgets"
+ page.order = 30
+
+ local page = node("admin", "freifunk", "widgets", "widget")
+ page.target = cbi("freifunk/widgets/widget")
+ page.leaf = true
+
+ local page = node("freifunk", "search_redirect")
+ page.target = call("search_redirect")
+ page.leaf = true
+end
+
+function search_redirect()
+ local dsp = require "luci.dispatcher"
+ local http = require "luci.http"
+ local engine = http.formvalue("engine")
+ local searchterms = http.formvalue("searchterms") or ""
+ if engine then
+ http.redirect(engine .. searchterms)
+ else
+ http.redirect(dsp.build_url())
+ end
+end