summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-firewall/luasrc/controller
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-firewall/luasrc/controller
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-firewall/luasrc/controller')
-rw-r--r--applications/luci-app-firewall/luasrc/controller/firewall.lua23
1 files changed, 23 insertions, 0 deletions
diff --git a/applications/luci-app-firewall/luasrc/controller/firewall.lua b/applications/luci-app-firewall/luasrc/controller/firewall.lua
new file mode 100644
index 000000000..5a6ab0ad3
--- /dev/null
+++ b/applications/luci-app-firewall/luasrc/controller/firewall.lua
@@ -0,0 +1,23 @@
+module("luci.controller.firewall", package.seeall)
+
+function index()
+ entry({"admin", "network", "firewall"},
+ alias("admin", "network", "firewall", "zones"),
+ _("Firewall"), 60)
+
+ entry({"admin", "network", "firewall", "zones"},
+ arcombine(cbi("firewall/zones"), cbi("firewall/zone-details")),
+ _("General Settings"), 10).leaf = true
+
+ entry({"admin", "network", "firewall", "forwards"},
+ arcombine(cbi("firewall/forwards"), cbi("firewall/forward-details")),
+ _("Port Forwards"), 20).leaf = true
+
+ entry({"admin", "network", "firewall", "rules"},
+ arcombine(cbi("firewall/rules"), cbi("firewall/rule-details")),
+ _("Traffic Rules"), 30).leaf = true
+
+ entry({"admin", "network", "firewall", "custom"},
+ cbi("firewall/custom"),
+ _("Custom Rules"), 40).leaf = true
+end