summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-dnscrypt-proxy
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2017-08-18 09:04:09 +0200
committerDirk Brenken <dev@brenken.org>2017-08-18 09:04:09 +0200
commit4a9b391d03a97fd948ce79a6fe2bded7a03e215f (patch)
tree962139096c3d50c1a6582b7a72f29a64cc6a23c9 /applications/luci-app-dnscrypt-proxy
parent14dca2f3eef863c03b87bf21dc5787a524d84b62 (diff)
luci-app-dnscrypt-proxy: fix ssl dependency
* remove libustream-mbedtls dependency in makefile and check for 'libustream-ssl.so' in the app. (fix for #1310) * add missing uclient-fetch dependency in makefile. Signed-off-by: Dirk Brenken <dev@brenken.org>
Diffstat (limited to 'applications/luci-app-dnscrypt-proxy')
-rw-r--r--applications/luci-app-dnscrypt-proxy/Makefile2
-rw-r--r--applications/luci-app-dnscrypt-proxy/luasrc/model/cbi/dnscrypt-proxy/overview_tab.lua7
2 files changed, 8 insertions, 1 deletions
diff --git a/applications/luci-app-dnscrypt-proxy/Makefile b/applications/luci-app-dnscrypt-proxy/Makefile
index ec4a1d976..4b632b8d0 100644
--- a/applications/luci-app-dnscrypt-proxy/Makefile
+++ b/applications/luci-app-dnscrypt-proxy/Makefile
@@ -5,7 +5,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI support for DNSCrypt-Proxy
-LUCI_DEPENDS:=+libustream-mbedtls +dnscrypt-proxy
+LUCI_DEPENDS:=+uclient-fetch +dnscrypt-proxy
LUCI_PKGARCH:=all
include ../../luci.mk
diff --git a/applications/luci-app-dnscrypt-proxy/luasrc/model/cbi/dnscrypt-proxy/overview_tab.lua b/applications/luci-app-dnscrypt-proxy/luasrc/model/cbi/dnscrypt-proxy/overview_tab.lua
index ea61366b1..de23ba00d 100644
--- a/applications/luci-app-dnscrypt-proxy/luasrc/model/cbi/dnscrypt-proxy/overview_tab.lua
+++ b/applications/luci-app-dnscrypt-proxy/luasrc/model/cbi/dnscrypt-proxy/overview_tab.lua
@@ -11,6 +11,13 @@ local plug_cnt = tonumber(luci.sys.exec("env -i /usr/sbin/dnscrypt-proxy --vers
local res_list = {}
local url = "https://download.dnscrypt.org/dnscrypt-proxy/dnscrypt-resolvers.csv"
+if not fs.access("/lib/libustream-ssl.so") then
+ m = SimpleForm("error", nil, translate("SSL support not available, please install an libustream-ssl variant to use this package."))
+ m.submit = false
+ m.reset = false
+ return m
+end
+
if not fs.access(res_input) then
luci.sys.call("env -i /bin/uclient-fetch --no-check-certificate -O " .. res_input .. " " .. url .. " >/dev/null 2>&1")
end