summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-ddns
diff options
context:
space:
mode:
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>2015-03-20 09:06:11 +0100
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>2015-03-20 09:06:11 +0100
commit39029888782ce7ea6862cbdfd4322e8b6b14843e (patch)
treefceb0c1291f5ca38620649ff182accb2b1361ebb /applications/luci-app-ddns
parent6160a53ab992e998adcda7119e49096a65a7f5de (diff)
luci-app-ddns: fix errors in global.lua
fix dispatcher and validation errors in global.lua Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
Diffstat (limited to 'applications/luci-app-ddns')
-rw-r--r--applications/luci-app-ddns/Makefile2
-rw-r--r--applications/luci-app-ddns/luasrc/model/cbi/ddns/global.lua2
2 files changed, 2 insertions, 2 deletions
diff --git a/applications/luci-app-ddns/Makefile b/applications/luci-app-ddns/Makefile
index f20b49e90..1bffcaa4b 100644
--- a/applications/luci-app-ddns/Makefile
+++ b/applications/luci-app-ddns/Makefile
@@ -10,7 +10,7 @@ PKG_NAME:=luci-app-ddns
# Version == major.minor.patch
# increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.2.1
+PKG_VERSION:=2.2.2
# Release == build
# increase on changes of translation files
diff --git a/applications/luci-app-ddns/luasrc/model/cbi/ddns/global.lua b/applications/luci-app-ddns/luasrc/model/cbi/ddns/global.lua
index e1718739f..fbd3cb337 100644
--- a/applications/luci-app-ddns/luasrc/model/cbi/ddns/global.lua
+++ b/applications/luci-app-ddns/luasrc/model/cbi/ddns/global.lua
@@ -35,6 +35,7 @@ local ns = m:section( NamedSection, "global", "ddns",
.. [[<a href="http://wiki.openwrt.org/doc/uci/ddns#version_2x1" target="_blank">]]
.. translate("For detailed information about parameter settings look here.")
.. [[</a>]]
+ )
-- section might not exist
function ns.cfgvalue(self, section)
@@ -119,7 +120,6 @@ ll.title = translate("Log length")
ll.description = translate("Number of last lines stored in log files")
ll.rmempty = true
ll.default = "250"
-ll.datatype = "and(uinteger,min(1))"
function ll.validate(self, value)
local n = tonumber(value)
if not n or math.floor(n) ~= n or n < 1 then