summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-attendedsysupgrade/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <paul@spooren.de>2017-07-28 00:28:12 +0200
committerJo-Philipp Wich <jo@mein.io>2017-08-02 22:28:50 +0200
commitb90153386cf890aa551e2b4457e9092d4c5b4867 (patch)
tree419d4a2b5a8940f648a99ed99653877930979753 /applications/luci-app-attendedsysupgrade/Makefile
parentbf407f087cde592631bd0c95948e32cbd0efab08 (diff)
luci-app-attendedsysupgrade: add package
Add a simple luci view in system tab to perform a sysupgrade with no hassle. Asks an external update server for upgrades, downloads and flashes the upgrade. This packge is the frontend for my current GSoC project: https://summerofcode.withgoogle.com/projects/#5684958571003904 More code is found here: https://github.com/aparcar/gsoc17-attended-sysupgrade Signed-off-by: Paul Spooren <paul@spooren.de> [jo@mein.io: squash commits, remove PKGARCH from Makefile] Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'applications/luci-app-attendedsysupgrade/Makefile')
-rw-r--r--applications/luci-app-attendedsysupgrade/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/applications/luci-app-attendedsysupgrade/Makefile b/applications/luci-app-attendedsysupgrade/Makefile
new file mode 100644
index 000000000..32992e19d
--- /dev/null
+++ b/applications/luci-app-attendedsysupgrade/Makefile
@@ -0,0 +1,11 @@
+# See /LICENSE for more information.
+# This is free software, licensed under the GNU General Public License v2.
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=LuCI support for attended sysupgrades
+LUCI_DEPENDS:=+luci-base +rpcd-mod-attendedsysupgrade
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature